12

Consider the following text, with the cursor placed at the end of the text (in place of where the vertical bar is):

Don't test me sunshine|

Pressing Ctrl+Backspace will yield the following in certain cases (e.g. when there is a space/more words after the cursor):

Don't test me|

I would much rather prefer the following result (with the space in place):

Don't test me |

Is there an option where I can force this behaviour?

3
  • Use the other keyboard shortcut for delete word, CTRL+Backspace and then Space. Apr 21, 2013 at 0:51
  • 3
    Out of all the programs I use, Microsoft Word is the only one I noticed that deletes the space with Ctrl + Backspace. Very strange and annoying - wish there was a better solution than the marked answer. Dec 23, 2015 at 13:25
  • Outlook also has this behaviour for me unfortunately. And I believe it hasn‘t been there always and only since 2010 (but maybe I remember this wrong)
    – bugybunny
    Nov 1, 2018 at 10:21

5 Answers 5

4

I believe this is considered a feature (as most users would also want the space removed). I don't know of anyway to configure the Ctrl + Backspace behavior.

One alternative would be to hold Ctrl + Shift and then Left Arrow to highlight the word. Then press the Spacebar.

2
  • Thanks, I guess I expected this. Though I wasn't aware of the word highlight shortcut, that might be useful. Apr 22, 2013 at 17:18
  • "as most users would also want the space removed" Why? This has always bugged me and I'm not sure about the rationale behind it. 99.99% of the times I use Ctrl+ Backspace, it's because I want to remove the previous word and type a new one. I use that shortcut everywhere and MS-Word is the only program where I encountered this behavior. May 28 at 12:34
9

After some hunting on the net, I found this feature is optional (kind of).

Word options->Advanced->Cut, Copy and Paste->Use smart cut and paste->Settings->Adjust sentence and word spacing automatically.

Source: http://answers.microsoft.com/en-us/msoffice/forum/msoffice_word-mso_windows8/control-backspace-deletes-previous-word-and-the/aa87aa3d-5928-4dd1-9266-b914f9c14620?auth=1


Note: This solves the problem when writing a new paragraph, but when deleting words with more words following it the same default behaviour occurs.

For example (if | represents the cursor/"insertion point"):

Lorem ipsum dolor sit amet|

Then Ctrl + Backspace works as normal (with or without a space before the cursor):

Lorem ipsum dolor sit |

But in the case of:

Lorem ipsum dolor sit| amet

With the cursor directly after the word to be deleted, Ctrl + Backspace will result in Word's default behaviour:

Lorem ipsum dolor| amet

As far as I can tell this isn't in the settings, so bear in mind that there's a bit of inconsistent behaviour if Adjust sentence and word spacing automatically is turned off.

3
  • It's probably not as common as you might think and it's behavior is a matter of opinion. Your suggestion would mean that a user that wants to remove a work would have to hit Backspace and additional time after removing a word in order to avoid a double space. There are pros and cons to both behaviors.
    – Seth
    Oct 11, 2016 at 10:27
  • 1
    @Seth you're right, I can see why the inconsistent behaviour might be preferable for some. Personally, the reason I see this is as undesirable is because not removing the space is the default behaviour for all of the applications that I do a lot of typing in (browsers, text editors, IDEs, etc.). The typing style I've come to adopt involves a lot of Ctrl + Backspace to fix spelling errors or replace words, whether that's at the end of a paragraph or in the middle of one. It's frustrating for me to then go write in Word and have to interrupt myself to insert extra spaces.
    – Grimeh
    Oct 12, 2016 at 15:47
  • Not really a solution but maybe an acceptable workaround? Mark the word using Ctrl+Shift+Left Arrow and afterwards delete it using either Del or Backspace. Suggestion from the answers of that question: Microsoft Word deletes a space along with the word when pressing Ctrl+Backspace. How do I prevent it from removing the space?
    – Seth
    Oct 13, 2016 at 5:45
2

If Ctrl+Shift+Left Arrow and then Backspace is the desired behaviour:

  1. Create a macro of that behaviour, in Word press Alt+F11
  2. Under Normal, Right click on the Modules folder, then Insert > Module
  3. Paste the below macro Should look something like this
  4. Assign it to Ctrl+Backspace

    (File --> Options --> Customize Ribbon --> Keyboard Shortcuts: Customize...
    Categories: Macros Find your newly created macro

Macro:

Sub CtrlBackspace()  
'  
' CtrlBackspace Macro
'
'
    Selection.MoveLeft Unit:=wdWord, Count:=1, Extend:=wdExtend
    Selection.TypeBackspace
End Sub
0

As of 2021, the Ctrl + Shift + Left Arrow and then Backspace also erases the space before the word. The best solution is already given; once the automatic word spacing is disabled, this functions as expected.

-1

This behaviour ceases entirely if you disable smart cut and paste in Advanced settings. Edit: turns out that's only for cut and paste, delete displays the aforementioned incomplete functionality.

2
  • This information has already been given in a previous answer.
    – zx485
    Jul 10, 2021 at 1:27
  • Actually, I thought I had found an upgrade. Jul 16, 2021 at 10:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.