0

I have a Samsung 7 Gamer laptop that comes with Windows 8 installed. I have an MSDN subscription and I wanted to install Windows 8 Pro. I have tried both adding the Pro code into the pre-installed Windows as well as a fresh clean install.

Windows Update is having problems. Updates are listing as being available but once the download starts it seems to just stop and go back to the list of updates. Or it sometimes says there are no updates available at all.

I have looked on the net and tried various steps there such as uninstalling my NVidia drivers, disabling all start-up services except Microsoft ones and running sfc /scannow via a command prompt.

I have looked into the log file and am seeing a few errors like these:

2013-04-21  15:26:29:464    1124    d74 DnldMgr   Download job bytes total = 1989293, bytes transferred = 1330139
2013-04-21  15:26:30:977    1124    5d0 WuTask  Uninit WU Task Manager
2013-04-21  15:26:31:352    1124    106c    Agent     * WARNING: Exit code = 0x8024000B
2013-04-21  15:26:31:352    1124    106c    Agent   *********
2013-04-21  15:26:31:352    1124    106c    Agent   **  END  **  Agent: Finding updates [CallerId = AutomaticUpdates]
2013-04-21  15:26:31:352    1124    106c    Agent   *************
2013-04-21  15:26:31:352    1124    106c    Agent   WARNING: WU client failed Searching for update with error 0x8024000b

Then further on:

2013-04-21  15:26:32:649    1124    d3c AU  WARNING: Failed to get Wu Exemption info from NLM, assuming not exempt, error = 0x80070490
2013-04-21  15:26:32:649    1124    d3c AU  UpdateDownloadProperties: download priority has changed from 3 to 2.
2013-04-21  15:26:32:649    1124    d3c AU  WARNING: Failed to change download properties of call, error = 0x80070057

It's almost like it starts to download then just decides to give up. I did manage to persuade some very small updates to install. But the others just fall over.

Any help appreciated!

5
  • what does the log say? %windir%\windowsupdate.log – Logman Apr 21 '13 at 3:07
  • also, they are downloaded but fail when they install? I would try "wuauclt.exe /detectnow" from the cmd prompt and then check the log file. – Logman Apr 21 '13 at 3:07
  • 8024A000 = WU_E_AU_NOSERVICE. share the requested log so that we get more details. – magicandre1981 Apr 21 '13 at 5:58
  • @Logman I have added some parts of the log showing errors, I wasn't sure how to share the full log on this site, but can do if that helps – Firedragon Apr 21 '13 at 14:37
  • Upload to any file sharing or pastebin type site that doesn't require registration to view/download, then paste the link here. – Karan Apr 21 '13 at 17:53
2

Try the following, copy the text into a textfile (Notepad). SaveAs or change the file extension to "resetWSUS.bat" instead of ".txt". Execute the script by right clicking the bat file and selecting "..Run as Administrator". You must run the script as administrator.

This script will turn off a couple services, rename the folders and register a few dlls that Windows Update Services use.........

ECHO ON
net stop wuauserv
net stop bits
net stop cryptsvc

ren %systemroot%\System32\Catroot2 Catroot2.old
ren %systemroot%\SoftwareDistribution SoftwareDistribution.old

regsvr32 c:\windows\system32\vbscript.dll /s
regsvr32 c:\windows\system32\mshtml.dll /s
regsvr32 c:\windows\system32\msjava.dll /s
regsvr32 c:\windows\system32\jscript.dll /s
regsvr32 c:\windows\system32\msxml.dll /s
regsvr32 c:\windows\system32\actxprxy.dll /s
regsvr32 c:\windows\system32\shdocvw.dll /s
regsvr32 wuapi.dll /s
regsvr32 wuaueng1.dll /s
regsvr32 wuaueng.dll /s
regsvr32 wucltui.dll /s
regsvr32 wups2.dll /s
regsvr32 wups.dll /s
regsvr32 wuweb.dll /s
regsvr32 Softpub.dll /s
regsvr32 Mssip32.dll /s
regsvr32 Initpki.dll /s
regsvr32 softpub.dll /s
regsvr32 wintrust.dll /s
regsvr32 initpki.dll /s
regsvr32 dssenh.dll /s
regsvr32 rsaenh.dll /s
regsvr32 gpkcsp.dll /s
regsvr32 sccbase.dll /s
regsvr32 slbcsp.dll /s
regsvr32 cryptdlg.dll /s
regsvr32 Urlmon.dll /s
regsvr32 Shdocvw.dll /s
regsvr32 Msjava.dll /s
regsvr32 Actxprxy.dll /s
regsvr32 Oleaut32.dll /s
regsvr32 Mshtml.dll /s
regsvr32 msxml.dll /s
regsvr32 msxml2.dll /s
regsvr32 msxml3.dll /s
regsvr32 Browseui.dll /s
regsvr32 shell32.dll /s
regsvr32 wuapi.dll /s
regsvr32 wuaueng.dll /s
regsvr32 wuaueng1.dll /s
regsvr32 wucltui.dll /s
regsvr32 wups.dll /s
regsvr32 wuweb.dll /s
regsvr32 jscript.dll /s
regsvr32 atl.dll /s
regsvr32 Mssip32.dll /s

net start wuauserv
net start bits
net start cryptsvc


PAUSE
1
  • Sorry for the very late response. I will try this script later. As it turns out I narrowed it down to the Modeshift Samsung application. If this is installed then it stops Windows Update working. I did contact Samsung but they were as much help as a chocolate teapot. – Firedragon May 1 '13 at 9:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.