Is there any non-violant way to disable horizontal scrolling in VLC (2.0.6) on OS X Mountain Lion? I went through the Preferences but couldn't find anything concerning the matter.

I could do something with AppleScript, but I'm wondering if it's just possible within VLC itself.

The reason I want to disable it is that when I accidentally don't fully gesture to another "space" (two fingers) I will mess up the play-position inside VLC.

  • 1
    Does anyone here know how to disable the gestures in VLC 2.2.4? I tried what was suggested in the top answer, but I couldn't find anything that looked like "MouseWheel up-down axis Control" in the preferences. – Elias Zamaria Jan 17 '17 at 7:03

This answer concerns VLC 2.0.7, but may work for previous versions.

In the menu bar select VLC -> Preferences

Then press Show All

Navigate to Interface -> Hotkey Settings -> Hotkeys

And change MouseWheel up-down axis Control to Ignore

Then restart VLC (VLC-> Quit)

This option is not well named as it only specifies the up-down axis. However, setting it to ignore disables both the up-down and left-right axis.

  • 1
    Thank you for your answer eltommo. It indeed disables the vertical gestures for volume control too. It's not that bad tho, I'm mostly concerned about the horizontal as it often accidentally scrolls my VLC movie when try to swap another Space in OSX. – User2910293 Aug 1 '13 at 16:27
  • 1
    @Allender Yeah, the accidental skipping was driving me insane; it's worth sacrificing the volume control in my opinion. – eltommo Aug 2 '13 at 1:35
  • Definitely agree :) – User2910293 Aug 2 '13 at 16:16
  • Skipping is not as bad as blowing ears when using earphones, or the speakers at 200% volume, or which ever comes first :). Very useful when watching screencasts where you instinctively try to scroll what's in a video. – John Doe Oct 16 '16 at 5:27
  • Does this still work for people? I have both set to ignore and I can still scroll to seek and change the volume. – Colin Marshall Oct 29 '19 at 23:39

For Catalina (10.15) and VLC (

VLC > Preferences > Show All > Interface > Hotkeys settings > Mouse wheel horizontal axis control > Ignore

Then Save.

(You might need to completely exit the app and restart it to have effect.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.