7

I just bought the Razer Blackwidow 2013 keyboard, and after installing drivers (Synapse 2.0) I run into a strange issue:

My function keys started to work very strange. They started to use their "shortcuts" (not sure how to properly name it) without the need to tap fn key + function key.

For example: F9 starts Macro recording instead of MissionControl. And now to achieve default behavior I need to press fn key with function keys.

Without drivers, function keys work fine (F9 for MissionControl etc). Also I can tap fn key + a function key to use a shortcut: turn sound on/off, stop/play music etc. But without drivers I can't use on the fly macro recording, which is why I decided to install Synapse.

If I turn on "Gaming Mode" everything works as expected. Functional keys behavior is default. And if I tap fn + function key shortcuts works fine.

My question is: is there a workaround to get default functionality without the need to use "Gaming Mode"? Because for now everything seems to work "inside out".

  • As a user of this keyboard what you describe sounds like normal behavior. – Ramhound Apr 22 '13 at 14:59
  • 1
    Normal behavior = everything works as described in the user guide (you should press the fn key to use functional keys shortcuts). But for me all shortcuts work without the fn key. Only when I turn game mode on all works fine. – user1457 Apr 22 '13 at 15:17
  • You sure you turning game mode on instead perhaps turning it off? – Ramhound Apr 22 '13 at 15:36
  • 1
    100% sure. Because when gaming mode is turned on I see green G on the top right corner of the keyboard. BTW in the Windows 7 all things work as expected, and it's not necessary to turn gaming mode on to get default behavior of functional keys. – user1457 Apr 22 '13 at 15:47
  • i'm also affected by this. synapse is a horribly broken software. I installed it for mapping the M1-5 keys, at first they were working but now they stopped working too. and i too have to enable gaming mood for normal operation of F keys :| – Sarim Feb 20 '14 at 9:22
-2

I have the same issue on OSX. I think the problem isn't related to the keyboard or synapse but to OSX. Indeed, on a MAC functions keys use the "shortcuts" (lights, volume) without fn pressed. You should try to go in System Settings, keyboard and then select "Use F1, F2 as standard function key"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.