Internet Explorer crashes on startup unless using remote desktop, Windows 7, IE 9.

Even in safe mode. Yet it works just fine when using the computer via Remote Desktop.

Does anyone have an idea how to fix it?

I have tried:

  • Diffrent users
  • Safe Mode
  • 64 Bit
  • 32 Bit
  • Running the IE 9 installer "Internet Explorer 9 is already installed on this system."

This started after a Windows Update. I can't get to the "Manage Add-ons" to disable all "toolbars and extentions". IE crashes before I get that far.

  • What is the history? when did this begin? Go to menu Tools "Manage Add-ons" and disable all "toolbars and extentions" and test again (just to test). Is it set to open any web page or home page on startup? did you set to a blank page to test? – Psycogeek Apr 23 '13 at 21:04
  • see also some tips (a few) here superuser.com/questions/268359/… for checking IE in It's own safe mode, and checking the events log for errors. – Psycogeek Apr 23 '13 at 21:12
  • 1
    I am thinking a "remote desktop" is probably using a "software" render type, as overlay and 3D type renders are not as used/useful in that situation. So that is one difference that might exist in this situation. – Psycogeek Apr 23 '13 at 21:16
  • KronoS, Brad Patton, Simon, Tog, Afrazier - I fail to see how this isn't a real question. Could one of you please enlighten me? – NitroxDM Apr 24 '13 at 14:36

Well, it could be anything. Is it user-account related? Create a new user and test?

I would recommend you to launch IE and in options restore all settings to Default. Then, update IE to Internet Explorer 10.

Then, verify that you have Windows Defender running -- maybe run a full scan.

  • 1
    I have the same issue with all the users on the system. – NitroxDM Apr 24 '13 at 14:17
  • Windows Defender is running. Full scan found nothing. – NitroxDM Apr 24 '13 at 14:37

We had this exact problem as well. It also included Firefox (version 25.x) having crashing issues.

Our answer was to download and install the most current video driver for our video card. We think it was related to the type of page content being loaded (such as Flash) in combination with a buggy WU patch from M$.

Our Environment:

  • Dell OptiPlex 790
  • ATI Radeon HD6350 video card
  • Windows 7 (64 bit)
  • Internet Explorer 8 (and 9 after upgrading to see if that helped, which it didn't. We downgraded back to 8 after and it still worked).
  • Firefox 25.x

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.