My left speaker is busted and distorts like crazy. I have gone into System Preferences -> Sound and balanced the sound to the far right. That works, but then when I plug in a USB audio interface or some headphones the setting resets, and I have to go back into System Preferences -> Sound and pan back to center. Is there a way to tell my Mac not to use the left speaker?

Note: I'm quite comfortable using the Terminal.

  • In other words: I want to disable the speaker rather than routing the signal to the right. Apr 24, 2013 at 0:03
  • 3
    Is opening the Mac out of the question too then? Apr 24, 2013 at 0:03
  • Hmmm.. Might be worth answering with that nonetheless if you have the know-how. May helps someone else, seems like no too many answers so far. Apr 26, 2013 at 1:54

2 Answers 2


Although the instructions will vary depending on which Mac model you are using, another option is to open up the notebook, and either disconnect or plug the speaker. There are sites available (such as iFixIt) that have step-by-step instructions on how to open them up.

Again, if you can just disconnect the speaker, it will solve the problem, but depending on the notebook, it may be a simply plug or you may need to unsolder a connection. As with anything inside of a system, be careful, and ask for help if needed


Go to Settings

System Prefs -> Sound -> Balance.

Change this to full left or full right depending on which one is the working speaker.

  • 1
    The OP knows how to do this,  and the question explains why it’s not an adequate solution. Apr 14, 2020 at 1:19
  • 1
    Perfect, I was looking for that! The OP knows how to do it, but it was perfect for my problem.
    – Victor
    Mar 1, 2021 at 0:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .