0

I have downloaded the newest version 8.0.18051 of TeamViewer 8 from their website. It claims to be "compatible with Windows 8".

That may be true for a 32-bit OS, but I cannot get the downloaded setup.exe to install on either Windows 7 x64 or Windows 8 Pro x64. Win7 says it's not a Win32 application; Win8 just says "This app can't run on your PC".

However, I have TV 8.0.17396 running on my Win7 x64, because I upgraded it from an former TV7 version.

I have tried:

  • running in a compatibity mode
  • running as Administrator
  • turning off SmartScreen (Win8)
  • downloading TV7 and installing that

Please advise.

2
  • I downloaded the application and it installed fine on both Windows 7 64-bit and Windows 8 64-bit. I also tried it on Windows Server 2012 ( which is only 64-bit ) and it also worked.
    – Ramhound
    Commented Apr 24, 2013 at 11:20
  • I've also tried redownloading the installer several times from teamviewer.com/en/download/windows.aspx, that did not help.
    – zoagli
    Commented May 9, 2013 at 7:43

3 Answers 3

3

The usual reasons for Windows 7 reporting an exe as "Not a valid Win32 application" is for one of the following reasons:

  1. File is corrupt, bad, or missing.
  2. File is not designed for your version of Windows.
  3. File is a virus, worm, or other malware file.
  4. Hardware incompatibility.

It is most likely not option 2 as it is designed to run on Windows 7 and 8 - I'm running it on both OSes (64 bit)

3 is also unlikely if you've downloaded it from the Teamviewer website. Malware is possible if the code/site had been compromised but unlikely given the volume of users of this product who would have reported something by now.

4 is unlikely unless you have an underlying and undetected hardware issue.

If we look at the reasons for 1 we know your file isn't missing (it's not trying to run a pre-installed application with missing dependencies.) So we are faced with it being corrupt or bad - that is, the file hasn't successfully downloaded completely.

I've just downloaded the same version for Windows (I'm assuming the full version and not the portable version etc.)

Calculating the MD5 hash using WinMD5Sum on it I get the following:

46bc67b377a0c84b1174f51c6709b8ae

I would recommend running an MD5 sum on the version you've downloaded and compare with the code I've provided above. Unfortunately they don't provide a hash on their website to validate the exe downloaded is valid.

4
  • it would be quicker to just redownload the installer and try install it again than to download WinMD5Sum and the installer and calculate the hash. Just saying :) Commented Apr 25, 2013 at 14:42
  • 1
    I agree Taylor Gibb, it is quicker to download the installer again. If vendors (or downloader sites) post a hash of the installers then I compare my hashes against what they post (I prefer to calculate the hash on new apps before installing.) Been stung before with files that hadn't downloaded fully but appeared ok until installation time (eg a 4GB Linux ISO that had the right size but was dodgy.) If the hash is correct and they still experience problems then it could always be a problem with their OS installation - unlikely given they've used 2 separate OSes. :-)
    – Enigman
    Commented Apr 25, 2013 at 20:04
  • agreed, for larger stuff like Linux ISOs. Hashes are they way to go! Commented Apr 25, 2013 at 20:06
  • @Enigman: Thank you, the MD5 hash did the trick for me in the end. I had downloaded from the website with language set to English. This redirected me to download.teamviewer.com/download/TeamViewer_Setup.exe with an MD5 of 4BE1E2738FA50EFF08249BEF9A565727, i.e. not what you posted. Talking to TeamViewer support, however, the sent me a different download link: download.teamviewer.com/download/TeamViewer_Setup_en.exe (note the "_en") which indeed has the MD5 of 46BC67B377A0C84B1174F51C6709B8AE.
    – zoagli
    Commented May 9, 2013 at 7:50
5

Sounds like your download might be corrupt, try downloading another copy of the installer and install it again.

7
  • 6
    This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post.
    – Simon
    Commented Apr 24, 2013 at 11:17
  • 2
    @Simon - Some problems are as simple as saying the download is corrupt.
    – Ramhound
    Commented Apr 24, 2013 at 11:20
  • 6
    @Ramhound IMO this post fits better a comment than an answer! Even though it might be the solution but questions to clarify (Did you try...) should not be posted as Answers.
    – Simon
    Commented Apr 24, 2013 at 11:25
  • @Simon - I would normally agree. Something tells me the user hasn't verified the installer is even complete. If they said they actually tried the same installer on a 32-bit windows installation I might agree this particular answer should be a comment but the author didn't do that.
    – Ramhound
    Commented Apr 24, 2013 at 11:30
  • @Simon how would you rather me phrase "your download is corrupt, download the installer again" ? :) Commented Apr 24, 2013 at 23:15
1

As a fix-all solution, try initiating the installation through ninite.com - it's a tool that provides quick, dialogue-less setup for a number of software programs.

Simply select the program(s) (Teamviewer) you wish to install and scroll to the bottom and select "Download Installer".

The reason I suggest this is because it automatically runs a checksum on the download to verify its integrity (as Taylor Gibb suggested above), and runs the installer appropriate for your version of Windows (x86 or x64). It will also give you verbose error messages that might give you further indication to any other issues you might have.

As a side note, you can also simply use their installer again to download updated versions of the software you have installed.

Edit: Second side note, this website is reputable and recommended by many other reputable companies, just in case anyone says otherwise.

1
  • Thanks for the tipp, @moses. I didn't try it (see my response to the accepted answer), but I will keep ninite.com in mind for future issues.
    – zoagli
    Commented May 9, 2013 at 7:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .