My phone path is Computer\Model-Number\Phone. I wanted to use a util like windirstat on it but it doesn't recognize the path since it doesn't have a drive letter (I assume). I tried copying all my files using explorer and it choked up during the calculating time phase. I tried robocopy but got the error below. I tried mapping a drive before this step but it isn't on the network. I have no idea what I can do other than copy folders one at a time

C:\Users\MyUser>robocopy "Computer\Model-Number\Phone" c:\arch\phone /S /R:1 /W:1

   ROBOCOPY     ::     Robust File Copy for Windows

  Started : Wed Apr 24 14:33:48 2013

   Source : C:\Users\MyUser\Computer\Model-Number\Phone\
     Dest : c:\arch\phone\

    Files : *.*

  Options : *.* /S /COPY:DAT /R:1 /W:1


2013/04/24 14:33:48 ERROR 3 (0x00000003) Accessing Source Directory C:\Users\MyUser\Computer\Model-Number\Phone\
The system cannot find the path specified.
  • try starting Powershell instead of a Command prompt. Try running Get-PSDrive, and post the output. You might be able to Copy-Item -Recurse.
    – Zoredache
    Apr 24 '13 at 18:58
  • @Zoredache: No luck. I did it before and after i plugged in my phone and tried closing/opening my prompt/powershell. It had the same lines pastebin.com/DCyaGLTA
    – user3109
    Apr 24 '13 at 19:15
  • 1
    You may be out of luck. It doesn't sound like your device is presenting itself to the OS in a way that you will be able to use standard filesystem tools.
    – Zoredache
    Apr 24 '13 at 19:49
  • is it possible to share that folder on the network? that way you could map a drive letter to that network share
    – golimar
    Apr 25 '13 at 8:37
  • @golimar: nope, it doesn't let me
    – user3109
    Apr 26 '13 at 21:54

If your device is rooted, you could try using an app like Samba Filesharing for Android, which would then work via WiFi when connected to the same network as your computer. As it then would turn up in the network section, you can connect it and assign it a drive letter, which would solve your problem.

Before you ask: there seems to be no similar solution for unrooted devices. Background is: only root can use ports below 1000 (which would be needed for the default Samba/CIFS port) on Unix/Linux/Android, so these apps have to use a non-standard port. And, quoting from the description of one such Samba app named Samba Server: Windows: only works if you have a rooted device since windows does not support non-standard SMB ports.

Another solution might be available: if you can connect your device in UMS mode, it should appear like any USB stick or external USB disk, available via a drive letter in Windows. Most newer devices these days prefer MTP, but some at least leave the user the choice between the two.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy