2

I printed a web page into a pdf on my mac. How do I get rid of the links in it? I tried re-printing the pdf into another one to no avail.

3
  • 2
    I notice from your profile that you also have registered with askubuntu. There is an answer to your question on askubuntu here.
    – karel
    Apr 25 '13 at 6:04
  • Thanks! Is there a solution on a mac?
    – David Faux
    Apr 25 '13 at 7:51
  • 1
    @DavidFaux: The answer linked to above uses pdftk, which is available for OS X, Windows etc. as well.
    – Karan
    Apr 25 '13 at 14:19
2

This seems to be the top Google link to this question. So here is a programmatic answer:

ls *.pdf|xargs -n1 -I% pdfjam "%"

This will take all pdf files in the current directory and process them through pdfjam (sudo apt-get install pdfjam if you don't have it. On a mac, brew install pdfjam). Pdfjam will output the same filename, with '-pdfjam' suffix prior to the .pdf extension.

2
  • Doesn't work for me on a Mac 10.13.6 and pdfjam 2.08.
    – Tom
    Jan 17 '19 at 11:23
  • To install pdfjam, I ran apt-get install texlive-extra-utils.
    – twb10
    Jul 9 at 21:02
1

I think that the best way to get rid of it is to save file as a pdf one and edit it after. I once used PDFescape http://www.pdfescape.com/ it was pretty effective for me, although I used the most simple function - I needed to add some text and to erase another part. Also over here there is an instruction on editing pdf files, this might be helpful for you too.

0

I can suggest an easy way. If you use Open with Microsoft word (I am using 2013). When it asks for conversion confirmation press "yes". Then edit and remove them. Browsing by page would be easier. After finishing editing Export it to PDF. make sure you set Make Bookmark option on to get pdf navigation menu (bookmark).

0

Only for Mac Users: Open the document in preview, go to FILE -> Export. It then asks you where you want to save it and make sure the FOMRAT is PNG before you save it. This will get rid of all links.

0

My goal was simply making the hyperlinks not clickable – not completely removing them and the following worked for me:

  1. Opening the PDF in Chrome
  2. Opening the Print dialogue – Cmd+P or File -> Print
  3. Save as PDF

Produced the same document as the source one, just without the clickable hyperlinks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.