I installed Oracle VirtualBox on Win7, then I downloaded android-x86-4.2-20121225.iso from Android-x86 - Porting Android to x86. After I installed Android x86-4.2 on VirtualBox from ISO and creating fake SD Card for it, I tried to run it, but when I started it I saw these lines in console:

Detecting Android-x86... found at /dev/sda1

ANDROID root@x86:/ #

And no thing else. I tried that some times but result is the same. How I can solve this problem?

Update: Even I waited more than 20 minutes and nothing happen!

4 Answers 4


You just need to change the value of "androidboot.hardware" parameter in the grub command from "Android-x86" to "x86". You can do this by pressing "Tab" in the boot menu or by editing "isolinux.cfg" file on the installation ISO Image.

Hope this works for you.

  • Thank you,that works for me!Although it takes some times. Apr 25, 2013 at 19:21

I have an HP430 Laptop with Windows 7. I had the same problem. But I figured out the solution:

While booting the computer with Windows 7 I entered the BIOS menu. There was a option to optimize the PC for virtualization. I selected it. After that every thing ran smoothly.

Later I noticed that in VirtualBox, in system settings, the acceleration type was VT-x AMD, Nested Paging, PAE/NX. This was different before optimization.


The real answer appears 9 months ago on youtube:

  • Close VM
  • In the system tab under settings for the Android machine uncheck "hardware clock in UTC time"
  • In the display tab set graphics controller to "vboxvga" and enable 3D hardware acceleration

The "Android" screen should appears under one minute after the message ANDROID root@x86:/ # where you get stuck


You have to wait more. I think it will start, but you have just wait enough.

  • 2
    It's more likely that there are no graphics drivers in the recent ISO image. Official VirtualBox support is non-existant since ICS. Apr 25, 2013 at 8:21
  • @RistoSalminen I wait more than 20 minuets and no thing happen! Apr 25, 2013 at 9:27
  • Oh, that's sad. Then you have more serious/hard problem.
    – user218718
    Apr 25, 2013 at 17:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.