43

I want to concatenate multiple WAV files into a single WAV file using FFMPEG.

I have used the following command and it generates the required file.

Command:

ffmpeg -f concat -i mylist.txt -c copy output.wav

File :

#mylist.txt
file '1.wav'
file '2.wav'
file '3.wav'
file '4.wav'

But as you can see the problem is that I have to create a text file to specify the list of WAV files to concatenate.

I can do all these tasks, but I would prefer a single command something that looks like

ffmpeg -i 1.wav -i 2.wav -i 3.wav -i 4.wav output.wav 

or

ffmpeg -i "concat:1.wav|2.wav|3.wav|4.wav" -c copy output.wav

I have tried these two simple commands but they return just the voice of 1.wav Please help me write a single command( or correct the above 2 commands ) that achieves the desired result.

Please don't suggest other Media Encoders/Editors, I want to use FFMPEG only, as it is already installed and used at other places.

41

You could try using the concat filter; it requires re-encoding, and so will take more system resources (a pretty tiny amount on any vaguely modern computer in this particular case), but PCM -> PCM audio should be mathematically lossless. In your case, you would use something like:

ffmpeg -i input1.wav -i input2.wav -i input3.wav -i input4.wav \
-filter_complex '[0:0][1:0][2:0][3:0]concat=n=4:v=0:a=1[out]' \
-map '[out]' output.wav

If you have five input files, use n=5.

| improve this answer | |
  • 5
    Note: Don't customize [0:0][1:0][2:0][3:0] to match the number of files. Use that exactly as it says. The only thing you should change is the input files and n=4. – Keavon Mar 7 '15 at 22:40
  • 9
    @Keavon: are you sure? Here ffmpeg (version N-49352-gc46943e x64) complains Too many inputs specified for the "concat" filter. when I try to process only 2 inputs with the original code. It works though when I remove [2:0][3:0]... which makes sense to me since in this case there are no such things as streams 2:0 and 3:0... – Bigue Nique Apr 22 '16 at 19:03
  • 1
    I agree with @BigueNique. I too ran into the same error and though it feels a little silly, wrote some code to generate the proper sequence given n. – Ryan DuVal May 12 '19 at 18:54
28

I think the best option for wav is to use sox, not ffmpeg:

$ sox short1.wav short2.wav short3.wav long.wav

Solution comes from How do I append a bunch of .wav files while retaining (not-zero-padded) numeric ordering?

| improve this answer | |
  • 1
    This may work for .wav, but sox does not seem to support .mp3. – Aaron Franke Mar 7 '18 at 19:46
  • 3
    Question was precisely about .wav – Héctor M. Monacci Mar 16 '18 at 7:13
  • 1
    I know, I'm just adding a note for anyone who tries to use this method with non-wav files. – Aaron Franke Mar 16 '18 at 7:20
  • 1
    the question explicitly stated that a solution is required using ffmpeg only! – Manu Apr 3 '18 at 8:00
  • 1
    Be sure to put your desired output-file-name on the end of that argument list or you'll overwrite the last file listed! Luckily, I had another copy. Pressing enter too soon with sox is dangerous. It worked good for me, though. Thanks Héctor! – LonnieBest Sep 26 '18 at 6:00
15

The FFmpeg wiki mentions using the concat protocol is not possible with all file types. It works fine with most MPEG containers and bitstreams, but obviously not WAV files with PCM audio.

You don't necessarily have to create a temporary file and use that. With Bash (or other shells that support process substitution), you can do everything in a single command:

ffmpeg -f concat -i <( for f in *.wav; do echo "file '$(pwd)/$f'"; done ) output.wav

The process substitution <( ) creates a file—or, to be precise, a file descriptor—on the fly, which ffmpeg can read. This file will contain the path to every .wav file in the current directory. We have to prefix it with $(pwd) to get the correct path relative to your current directory, and not relative to the file descriptor.

Of course, the command within the substitution can be changed to something else.

| improve this answer | |
3

Another option is to use concat

ffmpeg -i "concat:file1.mp3|file2.mp3|file3.mp3" -acodec copy out.mp3

| improve this answer | |
  • 1
    Welcome to superuser: While this may or may not answer the question,(an answer has been accepted) it would be a better answer if you could provide some explanation why your solution works with detail and an easy to follow instructions. If you feel your answer is correct do these things and re-edit. Please take a couple of minutes and read:- superuser.com/help .Answering: superuser.com/help/how-to-answer, again welcome to superuser.Thankyou – mic84 Mar 24 '18 at 7:34
  • 2
    I tested this and it does not appear to work – Nick Long Aug 7 '19 at 13:56
  • 4
    This does not work. It only ends up using the first file. – Brad Dec 28 '19 at 21:43
  • I also tested it and it also only ends up using the first file. – MikeSchinkel Feb 20 at 4:45
  • this only works – user293004 Mar 1 at 16:12
1

In Win8's Cmd.EXE .BAT script:

Rem Get number of source files
For /F %%A In ('Dir *.3gp /B /A-D ^| Find /C /V ""') Do      Set FilCnt=%%A

Rem Build list of source filenames
Set Lst=
For    %%A In (     *.3gp                          ) Do Call Set Lst=%%Lst%% -i %%A

Rem Concat and Convert sources to target
FFMPeg.EXE %Lst% -filter_complex concat=n=%FilCnt%:v=0:a=1 -vn Output.OGG

This way, you don't bother with the source file names or the concat-count parameter.

| improve this answer | |
1

I seen people posting similar answers, but never this exact answer which works great.

sox "file*" output.wav

The above command will combine all the files and use the * symbol as a wildcard. You use the quotes to avoid having your shell perform the expansion. Instead we let sox perform the expansion that way any of your parameters will be applied to every audio file.

| improve this answer | |
  • Does sox guarantee a specific order of processing the files? – Arjan Apr 1 at 12:02
-1

You could use shntool for wav-files.

shnjoin -r none 01.wav 02.wav ...
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.