I have a generic printer (text only) connected to a linux PC via parallel port but suddently it will just refuse to print at a normal speed. Form a cople of pages per minute I'm stuck at a couple of pages per HOUR, written character by character. On windows it prints correctly.

  • I've tried to create a new printer on cups with no results
  • Changed /dev/lp0 permissions to 66 without any effect whatsoever
  • Removed xsane just in case ... nothing.
  • RAW write to the parallell port (cat file.txt > /dev/lp0) does the same.

I'll try a raw write to the port but it was working a month ago and I didn't modify any CUPS configuration when it started going slow.

Partially solved the problem by using libieee1284. VERY dirty solution since I cannot use a printing queue anymore but the program using the printer is my own and I could modify the printing routine to directly use the parallel port. Want the source code? ask for it if you are interested.
I still want to know if you have a better solution

  • 1
    What distribution and version? What machine, what printer? Anything in the log files? (Parallel ports are going the way of the dodo, which makes this not exactly the most popular setup, so...) – vonbrand Apr 25 '13 at 12:23
  • lubuntu quantal i386 fully up to date (which log files?). Printer is a generic dot matrix printer (no graphics, no PostScript), write to the port get the text. – NeonMan Apr 25 '13 at 14:44
  • 1
    Do you get high CPU use during printing, or any other strange things appear in 'top' or other resource monitors? – golimar May 7 '13 at 9:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.