11

I'm trying to install Windows 8 through a bootable USB flash drive, in UEFI Mode. However, while it does work when the drive is formatted as FAT for some versions of Windows 8, the version I want to install has a install.wim file bigger than 4Gb, so I have to use an NTFS file system on the flash drive, but I cannot boot in UEFI mode from it. In both cases I use a GPT partition table. Is booting from NTFS not possible in UEFI mode (strange, as is the file system used by Windows) or am I doing something wrong?

9

From the Wikipedia article on UEFI:

The UEFI specification explicitly requires support for FAT32 for system partitions, and FAT12/FAT16 for removable media; specific implementations may support other file systems.

Personally I've yet to encounter any motherboard manufacturer who has implemented NTFS boot support in their UEFI modules.

Update: As mentioned in the comments below, two years after I posted the above there are now at least a few motherboards available with UEFI NTFS modules.

  • 1
    As far as I know, the ASUS K75DE does. – Akeo Apr 1 '15 at 13:07
  • @pbatard: Thanks, good to see at least one OEM (any others known?) has managed to implement this. Oh, and thanks for Rufus; such an awesome utility! :) – Karan Apr 5 '15 at 3:44
  • 1
    I did test and exFAT did not work with my UEFI system. – Jay R. Wren Apr 29 '15 at 14:35
  • 1
    @Karan: I have now confirmed that Intel's Visual BIOS also seems to include an UEFI NTFS driver. At least that seems to be the case on a D54250WYK Intel NUC with the latest UEFI firmware... – Akeo May 21 '15 at 11:32
  • 1
    @JayR.Wren UEFI exFAT partition? "EFI isn't compatible with exFAT and exFAT isn't backwards-compatible with FAT32" – phuclv Apr 17 '17 at 8:27
18

The latest version of Rufus allows seamless UEFI boot from an NTFS partition.

If you select a Windows installation ISO, set the partition scheme to GPT partition scheme for UEFI computers and also set the file system to NTFS, Rufus will add everything required to allow booting NTFS partition from an UEFI system.

Outside of using Windows installation media, you can also create a "blank" NTFS bootable UEFI drive when running Rufus in advanced mode (enabled by clicking the while triangle near Format Options) by selecting UEFI:NTFS as the boot option. In this case, you will just have to copy an /efi/boot/bootx64.efi or /efi/boot/bootia32.efi on the NTFS partition for your system to boot from NTFS.

The way it works is by adding a small (256KB) FAT partition at the end of the drive that contains am EFI executable that loads a Free Software (GPLv3) NTFS EFI driver and hands over the boot to the regular EFI bootloader on NTFS partition. This allows the installation of Windows media that contain an install.wim larger than 4GB and other stuff...

For more on this see the UEFI:NTFS project on github.

[Disclaimer: I am the author of Rufus and UEFI:NTFS]

  • Will i be able to install windows on gpt partitions in uefi this way? Will the bios (and installation on mbr) be supported as well? – Rules Aug 25 '16 at 23:25
  • UEFI worked just fine!! But havent tried bios (Seems to work though I never got further than "choosing installation partition" in win setup ib bios mode) – Rules Aug 26 '16 at 16:07
  • @Akeo In the past I have had issues (not Rufus), where things would work only if I disabled some Secure UEFI settings in BIOS. I guess BIOS was allowing only certain 'trusted' uefi through. Do you know if the latest one with NTFS will work fine? (I have an ASUS MB) – Rahul Dec 4 '16 at 10:01
  • 1
    UEFI:NTFS is NOT compatible with SecureBoot (because it's not signed... and cannot be as Microsoft arbitrarily forbids anything GPLv3 from being signed, which is a complete abuse of power from them). So you MUST disable SecureBoot for UEFI:NTFS to work. However, you only have to disable it during the installation phase (you can reenable it afterwards and it will be as if it was never disabled), and if you validated that your ISO was official (by checking its SHA-1 for instance), the installation with SecureBoot disabled is no less trustworthy than it would be if it had been enabled. – Akeo Dec 5 '16 at 11:01
  • @Akeo Just saw this. Thank you for your time. I dint know we could re-enable secure boot after installation. I guess during normal OS boot (after installation), though the file system is NTFS, BIOS allows it through Secureboot, because it has been signed by Microsoft. – Rahul Dec 25 '16 at 5:19
1

First, what reads the install.wim file you mention? If it's read after the Windows kernel has taken control of the system, it shouldn't be necessary to put the file on the EFI System Partition (ESP), which must be FAT. Once the Windows kernel has loaded (and loaded its filesystem drivers, if they're in separate files), Windows should be able to read NTFS volumes just fine. My suspicion is that this is how it works; however, I don't know enough about the Windows installer to suggest how to point it to install.wim on a specific partition.

OTOH, if install.wim must be read while the EFI is still running, there may be a way to do it. The Clover EFI Tools package (available from this forum thread) includes an NTFS driver for EFI; however, I don't know the provenance of that driver, so I'm providing this pointer only reluctantly. To use it, you'd need to either load it manually from an EFI shell or use rEFInd to launch it automatically. I can't offer any specific advice on how to partition your disk or get the Windows installer to launch and recognize the files on the NTFS volume.

It's conceivable you could get it to work with another filesystem, too. rEFInd includes drivers for ReiserFS, ext2fs, ext3fs, and HFS+, all of which support over-4GiB files. The trouble, of course, is that Windows doesn't support these filesystems, so once Windows takes over, it would lose access to those files. Creating two partitions -- one with a Linux or OS X filesystem and one with NTFS -- and putting identical files on them might be a workaround.

0

I bumped into the same problem on a Lenovo T430s laptop. Its firmware refuses to boot from a NTFS formatted partition created by Microsoft Windows Download Tool.

Fortunately it is very simple to create a bootable FAT32 Windows installation USB disk and the best of it no tools are needed other than a working windows system already has, namely diskpart and explorer.

You can find the instructions in http://www.eightforums.com/tutorials/15458-uefi-bootable-usb-flash-drive-create-windows.html. Make sure to scroll to Option 2. It only uses diskpart and explorer. To sum it up: it creates an active FAT32 partition on the USB drive after which copying all files and folders from the Windows installation DVD is all that is needed.

0

Creating GPT partition is correct, there have to be 2 partition. The 1st partition is FAT with rEFInd, the 2nd partition is your NTSF. Since 2012, rEFInd released NTFS driver, for which it can scan any directory inside a NTFS file system. All you have to do is pointing to the loader inside the NTFS partition

-2

I tried to create a new FAT32 partition, then I copied modified BCD and other files into this partition (this could be done by bcdboot and bcdedit) - this worked. The first partition uses exFAT. Since Windows won't mount the second partition, you may need some tricks like microdrive driver (Removable USB Flash Drive as Local Disk).

GPT may also work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.