After returning from vacation during which several Windows updates were applied and my router suffered a hard power cycle, my Windows 8 Desktop can no longer ping other devices on the same subnet. Specifically:

  • Win8 can ping the router
  • Win8 can ping google.com (no internet connectivity problems at all!)
  • Win8 cannot ping a Win7 laptop, Android phone, or Airport express on the same network
  • Router can ping the Win8 machine (and all other devices)
  • Other devices cannot ping Win8 machine

Since the Win8 machine can ping the router and google, I don't think this can be a firewall setting issue (I have tried it with Windows firewall on and off), or a Private/Public network issue.

When the Win8 machine pings any local devices, ping returns 'Destination host unreachable' and the target IP winds up in the ARP cache as 'invalid' entries, with MAC Addresses of 00-00-00-00-00. I have tried adding a static ARP entry to the Win7 machine, but all that does is change the ping response to 'request timed out' instead of 'destination host unreachable'.

The Win8 machine's routing table looks normal to my non-network-techie eyes (the subnet in question is 192.168.1.*):

IPv4 Route Table
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
     20         On-link    306         On-link    306         On-link    306         On-link    276         On-link    276         On-link    276         On-link    306         On-link    276         On-link    306         On-link    276
Persistent Routes:

The oddest thing to me is that the Win8 machine can ping the router, and the router can ping the Win8 machine, which seems to eliminate most solutions I found with 2 days of goggling.

Any suggestions would be greatly appreciated!

migrated from stackoverflow.com Apr 26 '13 at 15:12

This question came from our site for professional and enthusiast programmers.

  • Is there a DNS server? I would try an entry in the HOSTS file and see if that worked. – Guy Thomas May 1 '13 at 18:29

Seems like your devices are not responding to ping requests. That does not mean they are not reachable.


  • Thanks for the feedback. I though the same thing, but I don't believe this is the issue, for a few reasons: - I took the steps outlined, and they made no difference - I can ping the other devices from each other - I turned Windows Firewall off on all Windows machines Note that I'm doing more than just ping; RDP and SQL (port 1433) also do not connect. If the ARP entry is invalid, I believe no connections would be allow whatsoever? – Eric Patrick Apr 26 '13 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.