10

I was able to change the rest of the IDE's fonts (i.e. menus, dialogs, etc.) by using the "override default fonts" fields in the IDE Settings/Appearance screen of the Settings dialog. But it doesn't seem to affect the font size of the folder/file tree in the left navbar. The default font there is so small I can barely read it. How can I change that font?

UPDATE: I also apparently cannot change the font in the editor. enter image description here

10

Font in the tree was not configurable in older versions. In the recent versions it should work using the configuration in Settings | Appearance.

To change the editor font use the Save As... button as you can't modify the default scheme.

  • Thanks, but as I said, I've tried using the Settings/Appearance tab. It changes the font in the menus and dialogs, but not the file tree. I'm using 6.0, which is the newest version available for Windows. But your instructions did allow me to change the editor font, so thank you for that. – EmmyS Apr 26 '13 at 16:56
  • Update to 6.0.2 and restart PhpStorm after changing the font. – CrazyCoder Apr 26 '13 at 17:16
  • According to that link, 6.0.2 has a limited 30-day license. – EmmyS Apr 26 '13 at 19:25
  • Don't worry, release version or a new EAP will become available before that, you can also always revert to the latest release build if EAP expires. – CrazyCoder Apr 26 '13 at 19:58
5

For 2017/2018 versions of PHPStorm it's under menu item PHPStorm > Preferences > Appearance & Behaviour > Apperance > Override default fonts by. Here you can change the font and the font size.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.