why does robocopy say this file is older?

Robocopy shows (I think I used /MIR and /L)

   2    M:\bk\laptopcopy\pics\
        Older              79248    regular-expressions-cheat-sheet-v2.png

None of the time stamps seem to reflect that though.

---- dir showing the modified time stamp
M:\>dir m:\bk\laptopcopy\pics
Tue 22 Jul 2008  05:01            79,248 regular-expressions-cheat-sheet-v2.png

>dir regular-expressions-cheat-sheet-v2.png
22/07/2008  05:01            79,248 regular-expressions-cheat-sheet-v2.png

---dir showing the creation time stamp----
>dir /t:c regular-expressions-cheat-sheet-v2.png
24/08/2008  16:04            79,248 regular-expressions-cheat-s

>dir /t:c regular-expressions-cheat-sheet-v2.png
24/08/2008  16:04            79,248 regular-expressions-cheat-s

--- dir showing the access time stamp    
>dir /t:a regular-expressions-cheat-sheet-v2.png
20/04/2013  11:23            79,248 regular-expressions-cheat-sh

>dir /t:a regular-expressions-cheat-sheet-v2.png
29/12/2010  14:31            79,248 regular-expressions-cheat-sh

Documentation says [1]

File        Exists In   Exists In        Source/Dest     Source/Dest   Source/Dest
Class       Source      Destination      File Times      File Sizes    Attributes
=========== =========== ================ =============== ============= ============
Lonely      Yes         No               n/a             n/a           n/a
Tweaked     Yes         Yes              Equal           Equal         Different
Same        Yes         Yes              Equal           Equal         Equal
Changed     Yes         Yes              Equal           Different     n/a
Newer       Yes         Yes              Source > Dest   n/a           n/a
Older       Yes         Yes              Source < Dest   n/a           n/a
Extra       No          Yes              n/a             n/a           n/a
Mismatched  Yes (file)  Yes (directory)  n/a             n/a           n/a

[1] What does robocopy mean by tweaked, lonely and extra?

Which mentions documentation and http://theether.net/download/Microsoft/Utilities/robocopy.pdf and http://www.lordgoogle.com/downloads/robocopy/robocopy.doc

  • The last set of time stamps seems to reflect older doesn't it? If M: is the Source and F: Destination. – N4TKD Apr 28 '13 at 0:46
  • @AlwaysLearning I don't think so. older is when source is older than dest. newer is when source is newer than dest. also I don't think it looks at access time(which that is), and, I think those access times are a case of Newer rather than Older. source>dest. See that table – barlop Apr 28 '13 at 7:15
  • Good point I move to SnycToy long ago, because of issues like these you may want to think about switching if you can. microsoft.com/en-us/download/details.aspx?id=15155 – N4TKD Apr 28 '13 at 12:27
  • @AlwaysLearning thanks i'll consider that. Currently I use beyond compare to check my copies sometimes. but I think 'beyond compare' might also do a copy, or syncing or sync related operations. I actually haven't ever used robocopy for my backups and have only just tried it now. Normally I use fastcopy but that is behaving in a similarly odd manner all of a sudden, which has never happened before. Though now I think about it, I did copy files to new hard drives 'cos I changed 2 hard drives in that computer. In which case I could delete the backup recreate it, and the problem won't recur. – barlop Apr 28 '13 at 13:52
  • @AlwaysLearning but I might dig a bit (or a lot if i'm nuts) just to figure out what is going on in more detail 'cos that often helps for the future. – barlop Apr 28 '13 at 13:55

I had the same issue and came across the following:


Basically, this indicates that you can use the /FFT switch to Assume FAT File Times (2-second date/time granularity).

Using this now and I no longer get 100000 identical files overwritten

  • i'll give that a try soon if I still have those paths/files, though in my case C:\ and F:\ are NTFS. Though the files were copied via (poss FAT) usb stick. anyhow, i'll try that soon. – barlop Oct 17 '14 at 21:41
  • The /FFT works - doesn't say one file is older/newer. Though both M:\ and F:\ are NTFS.. also I have the file elsewhere on F with all times other than access time the same, and with the other one robocopy doesn't require the /FFT for some reason. So, not only is it not the file system but it's not that one file comes from a usb and one doesn't. I don't at this stage know why it works or what's going on which is a bit disconcerting for if I was to use robocopy or another program with this issue. – barlop Oct 18 '14 at 0:33
  • this(showing seconds with a timestamp), may be relevant superuser.com/questions/591438/… – barlop Jun 27 '16 at 9:17
  • I'm going to unaccept this answer because I can't verify that this would've worked for me. I no longer have the files where that issue was, and I don't really use robocopy or anything for backup at the moment. And anyhow given that both were NTFS so I think this couldn't possibly be it. – barlop Mar 14 '18 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.