In Windows 7, when you hover over an application in your task bar, a preview is generated showing the contents of the application window.

Another option just displays the names of the windows.

Somehow, I've turned off the preview and it only displays the window names. How do I change it back?

up vote -1 down vote accepted

Right Mouse Click on the taskbar, go to properties and on the first tab, make sure 'Show window previews (thumbnails) is checked.

  • 6
    This looks like vista taskbar properties techiecorner.com/wp-content/uploads/2009/04/… Where it says "Show window previews". But this looks like Windows 7 taskbar properties beingpc.com/wp-content/uploads/2011/05/… Notice the Windows 7 one does not have "Show Window previews". – barlop Dec 6 '12 at 5:33
  • 1
    @barlop So how to enable this feature?! – Mr.Hyde Jul 6 '15 at 7:01
  • 1
    @Mr.Hyde Try another answer. The answerer doesn't know one windows version from another, and the questioner doesn't understand when something is or isn't an answer. If you're on Windows Vista try what he wrote and see how it goes. If you're on Windows 7, go for the answer on here like the other two that have 6+ votes – barlop Jul 6 '15 at 8:33

Right click on Computer » Properties » Advanced system settings » Advanced tab » Performance settings. Here, uncheck/check 'enable desktop composition'.

This will disable/enable preview of windows on the taskbar.

None of the Aero Peek settings or registry edits work.

WARNING: this will result in many other changes and cannot be easily undone.

  • 1
    Whoa, wait a second there. Enabling/disabling desktop composition will affect many things, not just the taskbar preview. Notably, most Aero-branded effects and flicker prevention when moving windows. – Zero3 Dec 28 '16 at 17:51

You need to enable Aero

Right click on your desktop -> personalize

Edit : Or you have recently installed an application that dosen't suport Aero, so you can't reenable it.

  • I am using Aero. I think this is what actually happened... something I installed (can't remember now what it was) disabled it. Thanks! – y0mbo Oct 22 '09 at 20:30
  • Since I can't answer the question directly, I'll post what worked for me here: Try checking your video card's driver. If the driver is out of date, that'll prevent Aero from drawing the thumbnails. I fixed the problem with a video card update. – J. Peterson May 31 '13 at 21:25
  • More useful information here: mydigitallife.info/… – J. Peterson May 31 '13 at 21:27

For me this was solved by copying (or rather screenshotting) all settings in "personalization", then activating the "Windows 7" theme, applying all settings again and then saving that as a theme.

protected by nhinkle Apr 26 '11 at 23:47

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.