9

I have my home server up and running. I had my router set up so that it forward outside calls directly to the server so I could access it from anywhere. For some unkown reason it started misbehaving. I have no idea why it doesn't bind IP properly.

enter image description here

enter image description here

What am I missing? Binding seems to be enabled, MAC address seems to be the same...

I use router TL-WR941N with firmware version 3.13.9.

14

I'm using TL-WR1043ND.

Before setting Mac Binding, you have to reserve an IP address for the server in DHCP > Address Reservation.

  • 2
    Hey I just want to give you a hearty thanks for solving my home networking problem. It's weird that it doesn't let you add the address reservation from the Mac Binding page since those 2 things seem closely coupled – CornSmith Oct 5 '17 at 19:40
  • Agreed. Here's a related question: superuser.com/q/904476/52722 – StriplingWarrior Apr 9 '18 at 17:45
3

As mentioned in tp-link site. you should be disabled DHCP.

1

Two possibilities:

  1. Your server is using a dynamic IP rather than being statically assigned 192.168.0.150. Since the forwarding is always to 192.168.0.150, if the server is assigned a different IP address, the forwarding will no longer be to the server.

  2. You are testing from inside your own network. Forwarding of connections from the outside won't forward connections from the inside unless your router supports loopback (or "hairpin") NAT.

  • Isn't it the router who picks the IP address? Should I look into my server's settings to ensure it's binding to 192.168.0.150? – Pijusn Apr 28 '13 at 20:37
  • It can be either the router or the machine depending on how you configure it. Did you configure the router to assign the machine a static IP address? If not, did you configure the machine to use a static IP address? If you didn't do either, then it won't have a static IP address and the address can change. – David Schwartz Apr 28 '13 at 20:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.