I fixed the issued by reinstalling Windows.
A fresh install was not needed.
But I had to use the "Keep personal files only" option.
The "Keep Windows settings, personal files, and apps" option did not help.

As a side note, I want clarify that VS12 does not have an Uninstall context menu item in the Control Panel\Programs. It only has "Change" which should normally bring up a menu listing "Repair, Modify, Uninstall".

enter image description here

So I installed Visual Studio 2012 on Windows 8 x64, but it is acting very weird when I try to uninstall it.

When I click on the only available option "Change", only a brief flash of the VS2012 logo flashes and then nothing.

enter image description here

I cannot install the Visual Studio 2012 Update 2 either. It does the same "flash" even with the "/layout" command from the command prompt.

I have spent over an hour trying to figure this out. I am at a loss here.

Edit: Cannot reinstall either. Even with the direct ISO from Microsoft, the same "flash" occurs and then nothing. Also I did a full Malewarebytes scan and nothing came up.

Edit 2: Safe Mode did not help at all. Doing a Maleware scan in safe mode, just for the heck of it. Nothing found.

Edit 3: I cannot install/uninstall/update anything related to Visual Studio 2012. Not the ISO, Web Download, or Web Install. Nor any version type or platform type. Not even Windows Update will work. Nada, zip, nothing. I was able to install Visual Studio 2010 again.


2 Answers 2


Do you have any non-ASCII characters in your Windows user name?

Can you try installing the Visual Studio under another user (create a temporary account if you don't have another one - VS should work for all users then)?

  • I don't have any non-ASCII characters in my user name "Anonymous". Commented Apr 29, 2013 at 2:48
  • Could not install/uninstall/update VS12 on a different user. Same thing as before, quick flash and nothing. Commented Apr 29, 2013 at 3:37

If you still have the msi for Visual Studio 2012 (or look up the product code) you can try uninstalling it from the command line with:

msiexec /uninstall [location of msi/product code] /quiet

Full msiexec tutorial from Microsoft here:

Find your product code like this:

open system registry and search for HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall key (if it's a 32-bit installer on a 64-bit machine, it might be under HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Classes\CLSID instead). the GUIDs listed under that key are the products installed on this machine find the one you're talking about - just step one by one until you see its name on the right pane This GUID you stopped on is the ProductCode.

  • Found "Microsoft Visual Studio 2012" in the 64bit reg key you listed. The app ID was 179CAEE3-011C-424A-9A43-011AB589A7CC but when I ran msiexec.exe it gave me this: "This installation package could not be opened. Contact the application vendor to verify that this is a valid Windows Installer package. Commented Apr 29, 2013 at 4:51
  • I also tried it with the key name which was EB1425FE-3641-47AB-9484-32B62FC8B0B0 but got the same error. Commented Apr 29, 2013 at 4:54
  • BTW I am using "..\Windows\System 32\msiexec.exe" Commented Apr 29, 2013 at 4:55
  • The full command would be "msiexe /uninstall {179CAEE3-011C-424A-9A43-011AB589A7CC}" You need to add the braces. You can add additional switches at the end to attempt to make it work. Try /quiet or /passive at the end and see what works for you. At the very least try to get the error message.
    – Will
    Commented Apr 29, 2013 at 5:09
  • I found a program called msiinv.exe in which it lists all the MSI packages. So I am going through and doing "msiexec /x path" on anything with the name "Visual Studio 2012" in it. Although it hasn't had any affect on not being able to run the VS12 installer and reinstalling it. Commented Apr 29, 2013 at 5:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .