How do you open the Win 7 Firewall for incoming Remote Desktop connections?

I get this message in System Properties:

enter image description here


It is automatically created when you allow remote users.

Click Start -> Right click on Computer and select properties.

Then select Advanced System Protection. Click on the remote tab and enable it. The rule is automatically created for you.

Typically, the port used is 3389 so you may want to open that, or in your firewall, choose the RDP program.


Click the Start button Picture of the Start button, click Control Panel, type "firewall" in the search box, and then click Windows Firewall.

Click Allow a program or feature through Windows Firewall.

Under Allowed programs and features, scroll down to Remote Desktop and make sure its check box is selected.

Under Home/Work (Private), make sure the check box next to Remote Desktop is selected.


| improve this answer | |
  • When I do that I get You must enable the Windows Firewall exception for Remote Desktop in System Properties. See image above. – CJ7 Apr 29 '13 at 8:07
  • When you do which? I gave 3 options. check out the 3rd option :) – Dave Apr 29 '13 at 8:11
  • When I tried the third option Remote Desktop was not one of the listed programs. – CJ7 Apr 29 '13 at 8:36
  • @CJ7 Does you computer have a password? – Dave Apr 29 '13 at 9:04
  • Yes it does have a password. I think a recent Windows Update may have altered the firewall settings. – CJ7 Apr 29 '13 at 9:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.