4

I have a Service on automator that applies to Files and Folders in Finder. Initially it was saved as "Text" input.

Problem is, Finder won't show this Service to Files and Folders. If I go to settings, it's still placed under the "text" categories.

3
  • This works for me (1, 2). What do you mean by "Finder doesn't enable it"? – Daniel Beck Apr 29 '13 at 13:20
  • I created this as a new > service. But finder doesn't show it on the Service menu. If I go to settings, it's placed under the "text" categories. Also, even if I assign a shortcut, finder won't fire it against selected files and folders. – bluefoot Apr 29 '13 at 13:33
  • I've had problems with services possibly related to caching before. I solved those by File » Duplicate and entering a different name. Make sure to get it right the first time you save the new service. – Daniel Beck Apr 29 '13 at 13:42
10

OS X sometimes ignores changes to services after they've been saved in Automator, possibly due to caching. So if the service started out as a text service, chances are your changes aren't getting picked up. To circumvent this problem, select File » Duplicate in Automator and save the service under a new name, and try again. Then delete the original service from ~/Library/Services.

1
  • Thanks. It got me out of trouble with a service I was creating. – Manngo Jul 11 '16 at 7:29
0

In Addition to Daniel's answer, you may also consider restarting your computer. This should clear the cache if that's what really is causing the problem. Since this is definitely a bug, there is no absolute path. What worked for me after restarting was opening the service workflow in Automator, creating and saving the duplicate, wait, and finally see both the services on the menu. Next, I just deleted the duplicate service and it disappeared from the menu after a while.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.