I hope someone can shed some light on this one as this issue has been driving me up the wall for many months now.

I have a dual screen setup.

A Samsung SyncMaster 940UX on the left. Identified as monitor 1. A Viewsonic VA1931wa on the right. Identified as monitor 2.

Running Windows 7 with an Nvidia GeForce 210 graphics card.

All drivers are up to date according to the system.

Occasionally, everything on monitor 1 will switch with monitor 2. The left hand Samsung monitor is set up as my primary display and primarily I wish for applications to, by default, open on this screen and then I'll drag what I require over to the second Viewsonic screen.

It is incredibly frustrating as when I have a lot of apps running and windows open, I have to manually put everything back to the correct screens.

When everything on the screens has switched around, there is no change in the primary display or numbered identification of the monitors in display settings. All settings appear to remain the same.

When I boot up the system, the BIOS post screen appears on the right hand Viewsonic monitor and when it loads Windows 7, the login screen and everything else etc etc loads on the left hand Samsung primary display (if this is of any relevance).

  • Did you check the manual for the card to make sure it supports dual monitors? There was a similar question recently. – Ben Plont May 1 '13 at 3:09
  • Yes it supports dual screen, it wouldn't offer a VGA and a DVI output otherwise. – zigojacko May 1 '13 at 7:21

Are you running the latest Nvidia driver/software for your video adapter on your system? You stated "All drivers are up to date according to the system."...Huh? If up-to-date, try installing an earlier released driver and see if the issue still exists.

  • If you simply want the OP to clarify something before posting a definite answer, you should leave a comment instead. – Karan Apr 30 '13 at 15:41
  • Yes the Nvidia drivers are up to date. And yes, the issue was still apparent prior to the latest update. – zigojacko Apr 30 '13 at 16:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.