2

I recently upgraded from Windows 7 to 8 and am still learning the ins-and-outs of the upgrade. One thing I recently discovered was that Win8 replaces the Volume Shadow Copy Service with the new File History tools. More importantly, this is not on by default like I had assumed.

I have a large external hard drive that I use for all of my backups that has plenty of free space, yet File History refuses to identify that the drive is available to store the file history. Other than not showing in the File History tools, the drive appears and acts just fine. Any ideas why this drive would not be available to use with File History?

For reference, File History setup and other instructions available here: http://www.techrepublic.com/blog/window-on-windows/enable-windows-8-file-history-to-protect-your-data-revisited/7171

3

My problem was that I needed to be more observant. When you go to select a drive, File History will tell you (albeit in very small, gray text) that you cannot use a drive that is included in any libraries.

Select Devices screen in Win8 File History

I had several folders on this drive included in libraries. Since I don't particularly need/use libraries, I removed the folders and deleted the libraries themselves. After restarting, the drive appears as expected.

-1

The problem for me was drive permissions. I right-clicked the drive, went to the Security tab, and added myself explicitly with full permissions. After doing that, the drive finally appeared under "Available drives" in File History.

Just to give more context: the Security tab for the drive listed System, Administrators (with full permissions), and Users (with read-only permissions). I am part of the Administrators group, but apparently that wasn't enough for File History to recognize the drive.

I don't understand why the drive had these permissions set, which were different from other drives on my system. Besides the groups above, other drives, which did show up as available, had the "Authenticated Users" group as well (with read/write permissions). So, adding this group (or setting read/write permissions to the Users group) should work as well.

1
  • Why is this downvoted? Just freaking tell me why?? This is really annoying SO... at least implement this! :-|
    – Paul
    Jan 25 '18 at 22:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.