How could I mount an NTFS filesystem in a way that would allow all users full access to it? If I use sudo mount -t ntfs /dev/sda1 /media/drive, then only the root user can use it. It won't let me change the permissions/ownership on files after it's mounted (although folders are ok), which is really annoying.

  • 1
    tried ntfs-3g ? assuming you have the package with the same name? Apr 30, 2013 at 17:11
  • @D0rf i think that the ntfs option for mount uses ntfs-3g, it has dones so for a while now.
    – terdon
    Apr 30, 2013 at 18:06
  • @terdon thank you for the comment, it indeed seems to happen that way. Apr 30, 2013 at 19:30
  • Just to note that I solved a similar problem by installing the ntfs-3g package which I was missing. Maybe could be useful to someone.
    – Michele
    Sep 24, 2014 at 20:40

2 Answers 2


From man mount:

Mount options for ntfs

uid=value, gid=value and umask=value

    Set the file permission on the filesystem. The umask value is given in octal. By default, the files are owned by root and not readable by somebody else.

So you should be able to do what you're after with something like

mount -t ntfs -o umask=000 /dev/sda1 /media/drive

which should give everyone read and write permissions on the volume.

  • Thanks for the solution! Is there a way to add this to /etc/fstab, so that it may mount automatically with all permissions? Aug 22, 2018 at 5:51
  • Sure! You can use the same arguments in fstab as in the mount command; see man 5 fstab or the web equivalent for details on the format, or the leading comments which may be included in /etc/fstab on the system where you're looking to make the change. Aug 22, 2018 at 15:34

I am not sure, perhaps you need the allow_other option?

mount -t ntfs -o umask=000,allow_other /dev/sda1 /media/drive

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .