I just acquired a Dell XPS 12 ultrabook, with a flipping touchscreen. I like it, but only want to use the (small) touch screen when I'm away from home. I'd rather use synergy to control my new laptop from my desktop.

At first, it worked fine. I had an install window in the background on the laptop, and whenever that window came into focus, the client would stop moving the mouse in response to the server. I assume that's because install windows require administrator privileges, and thus synergy can't command such windows. This confused me at first, so I made a number of changes while this was going on, and have a hard time pinpointing what ultimately broke synergy.

At some point, perhaps when the background install finished or when I upgraded the server synergy version to 1.4.11, the client and the server both became unable to connect. For example, on the client:

NOTE: starting the client
NOTE: config file: XXXXXX
NOTE: log level: NOTE

with a similar message on the server. The status bar on the bottom of both windows would read "Synergy is starting." and the stop/start button would read "stop". I get the impression the server never gets started and the client never connects.

In this setup, the client was the XPS 12 laptop was a Windows 8 64 bit box running Synergy v1.4.11, and the server is a home-built desktop running Windows 7 64 bit and Synergy v1.4.11. I've tried with and without passwords enabled for synergy, I've tried disabling firewalls, I've tried both the 32 bit and 64 bit versions of Synergy, and nothing helps, or even produces a visible difference in behavior. Telling the client to connect to a bogus server IP address also produces no visible change in behavior -- it's as if the server isn't even there.

Both client and server report, in the log,

NOTE: connecting to service...
ERROR: ipc connection error, connection refused

over and over again, whether the client or server is "started" or "stopped". I don't know what this means, and I would like to. Is "ipc" inter-process communication? Is that even a network problem? Several past posts have suggested using the 32 bit version instead of 64 or reinstalling synergy.

Running the synergy server v1.4.10 from Ubuntu 13.04 produces better server-side results, but no connection. The dialog box is similar, but no warning about ipc, and when I click "start" it says

NOTE: stopping synergy desktop process
NOTE: starting server
NOTE: config file: /tmp/qt_temp.TT2295
NOTE: log level: NOTE
2013-05-01T00:44:24 NOTE: started server, waiting for clients

Then the configuration checkboxes for "server" and "client" etc. all gray out, and the status bar reports "Synergy is running (desktop mode). Version 1.4.11 is now available, visit website [link]". This is in contrast to "Synergy is starting." on Windows.

I haven't had a chance to install an Ubuntu partition on the laptop, but suspect better results. In the mean time, I don't know what else to try, beyond restricting myself to Ubuntu (I'm not religious about operating systems; I need both).

  • 1
    "ipc connection error, connection refused" sounds like something isn't listening on the same port as before. Can you verify the port # is what you expected?
    – Mark Allen
    May 1, 2013 at 6:27

1 Answer 1


Try starting the Synergy service in windows control panel. The ipc connection error usually means the service is stopped.


  1. Open your Windows Task Manager.
  2. Click on the Services tab.
  3. Right click on the Synergy service.
  4. Click Start Service.
  • Thank you! That was it exactly. I don't know why the service is dying, but I've had to restart it a few times (and reinstall synergy to do so). But I've got it working now, thanks.
    – Ed Krohne
    May 3, 2013 at 0:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.