I recently installed Ubuntu 13.04, and i add my ssh key to my github account, like always i did. I didn't had any problem to access to my own reports, i could clone my reports, etc... But today, maybe for any updates? (i don't know), i can't connect to github, it says: Permission denied. For sure, i have my key added. For my surprise, if i change to another terminal (ALT + CTRL + F3 for example) and i login with the same user than the default terminal with Unity (maybe there is the problem) i can connect!!

With the default terminal (Unity) if i run this command:

ssh -T git@github.com

it says:

Agent admitted failure to sign using the key. Permission denied (publickey).

But if i run the same command on another terminal, it ask for my passphrase (why in the default it doesn't ask me for my passphrase?) and it's run ok with the msg:

Hi --myname--!, You've succesfuly authenticated.....

Anyone knows what are happening?

post of ssh -vT git@github.com:

> OpenSSH_6.1p1 Debian-4, OpenSSL 1.0.1c 10 May 2012 debug1: Reading
> configuration data /etc/ssh/ssh_config debug1: /etc/ssh/ssh_config
> line 19: Applying options for * debug1: Connecting to github.com
> [] port 22. debug1: Connection established. debug1:
> identity file /home/daniel/.ssh/id_rsa type 1 debug1: Checking
> blacklist file /usr/share/ssh/blacklist.RSA-2048 debug1: Checking
> blacklist file /etc/ssh/blacklist.RSA-2048 debug1: identity file
> /home/daniel/.ssh/id_rsa-cert type -1 debug1: identity file
> /home/daniel/.ssh/id_dsa type -1 debug1: identity file
> /home/daniel/.ssh/id_dsa-cert type -1 debug1: identity file
> /home/daniel/.ssh/id_ecdsa type -1 debug1: identity file
> /home/daniel/.ssh/id_ecdsa-cert type -1 debug1: Remote protocol
> version 2.0, remote software version OpenSSH_5.5p1
> Debian-6+squeeze1+github12 debug1: match: OpenSSH_5.5p1
> Debian-6+squeeze1+github12 pat OpenSSH_5* debug1: Enabling
> compatibility mode for protocol 2.0 debug1: Local version string
> SSH-2.0-OpenSSH_6.1p1 Debian-4 debug1: SSH2_MSG_KEXINIT sent debug1:
> SSH2_MSG_KEXINIT received debug1: kex: server->client aes128-ctr
> hmac-md5 none debug1: kex: client->server aes128-ctr hmac-md5 none
> debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent debug1:
> sent debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY debug1: Server host
> key: RSA 16:27:ac:a5:76:28:2d:36:63:1b:56:4d:eb:df:a6:48 debug1: Host
> 'github.com' is known and matches the RSA host key. debug1: Found key
> in /home/daniel/.ssh/known_hosts:4 debug1: ssh_rsa_verify: signature
> correct debug1: SSH2_MSG_NEWKEYS sent debug1: expecting
> SSH2_MSG_NEWKEYS debug1: SSH2_MSG_NEWKEYS received debug1: Roaming not
> allowed by server debug1: SSH2_MSG_SERVICE_REQUEST sent debug1:
> SSH2_MSG_SERVICE_ACCEPT received debug1: Authentications that can
> continue: publickey debug1: Next authentication method: publickey
> debug1: Offering RSA public key: /home/daniel/.ssh/id_rsa debug1:
> Server accepts key: pkalg ssh-rsa blen 279 Agent admitted failure to
> sign using the key. debug1: Trying private key:
> /home/daniel/.ssh/id_dsa debug1: Trying private key:
> /home/daniel/.ssh/id_ecdsa debug1: No more authentication methods to
> try. Permission denied (publickey).
  • Can you post output of ssh -T git@github.com -v as well? That may help us find where it was rejected at.
    – Jokester
    May 1 '13 at 16:44
  • sure, i've done
    – Kalamarico
    May 1 '13 at 17:01
  • Why in default terminal it doesn't ask for my passphrase and in another terminal it's asking me?
    – Kalamarico
    May 1 '13 at 17:45

Github has an article on this issue.

For most users, simply running ssh-add to load your keys into the SSH agent will fix this issue.

$ ssh-add
# Enter passphrase for /home/you/.ssh/id_rsa: [tippy tap]
# Identity added: /home/you/.ssh/id_rsa (/home/you/.ssh/id_rsa)

If your key does not have the default filename, you'll have to pass the path to ssh-add

$ ssh-add ~/.ssh/my_other_key
# Enter passphrase for /home/you/.ssh/my_other_key: [tappity tap tap]
# Identity added: /home/you/.ssh/my_other_key (/home/you/.ssh/my_other_key)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.