I know the question isn't really about programming but it would be really nice if anyone would know how to recover a windows 8 recovery partition from my Dell Inspiron laptop (Inspiron 3420) that came pre-installed with it. I seem to have been rash and installed a linux fedora 17 version on a new small partition, but I cannot find windows anymore. so... I'll try to recall the details when I installed fedora from it's live cd from the start...

  1. I tried to boot from the CD but I think windows 8 has a new process for booting, since it didn't boot from the CD but kept bypassing it and booting as windows 8...
  2. tinkered with the f12 boot setup and first turned off the EUIF, didn't work, so I used legacy and then restarted it, then booted manually from the CD-ROM from F12 boot setup again... it worked and I was able to use fedora Live CD.
  3. from there, I installed Fedora 17 on a new partition of around 3 GB, now Fedora 17 is installed.
  4. I wanted to see if there was a dual boot option when I restarted my laptop but it seems that Fedora was the only option I could choose from the boot options (there wasn't windows 8)
  5. so.. I'm frustrated now.. since I cannot find windows 8 anywhere but the recovery partition is still intact that came with the laptop.. but I just can't access it anywhere from boot (I tried repeatedly typing F8 during the Dell logo, ctrl+F11, going back to boot menu to boot from hard disk), but I can't find any where that would direct me to restoring factory settings for the laptop. My guess is that Fedora has over-written some boot configuration file and erased any trace of the original Windows boot file that would enable it to get into windows 8. Oh, and one more point is that the hard disk option from boot setup cannot be found anymore from the boot order in boot setup (it disappeared from the option list), it was there before the Linux installation...

----- answer to answers... ---

Hi thank you for the answers... I did switch back to uefi both on secure mode on and off, it still just booted to linux without any option for windows 8...

I see... I'll try to find someone who can help to create a recovery CD for windows 8 thanks again... it's just strange that it feels so near yet so far... the partition for recovery is just there in my hard disk but the only problem is I can't reach it or execute it's setup file... I know that it was my risk doing the dual boot... but I wish dell could at least use F8 or some other shortcut in the boot screen just to access it's recovery options as IBM thinkpads have the blue button you just press during boot up to access it's entire range of recovery options...

well.. I guess that's it... I would be happy to reply if more details are needed... I think I may need to recover the original Windows 8 bootloader (I'm not sure what it's called) file, or find some way to access the recovery partition of my laptop.

Thank you.

migrated from stackoverflow.com May 1 '13 at 16:53

This question came from our site for professional and enthusiast programmers.

  • Did you switch back to the UEFI ROM in the BIOS? – infact May 1 '13 at 16:25

If Fedora overwrote the Windows 8 bootloader and you don't have a recovery cd you might be out of luck trying to access the recovery partition. Call Dell and let them send you a recovery media.

If you have access to another windows 7/8 computer you can create a recovery disk that will let you recreate the Windows bootloader. See http://www.eightforums.com/tutorials/2855-system-repair-disc-create-windows-8-a.html

Once booted into the recovery disk execute these commands in order.

bootrec /fixmbr
bootrec /fixboot
bootrec /scanos

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.