Whenever I have an application running (Visual Studio 2008, Notepad, etc.) under "Run as Administrator", I cannot drag and drop files from Windows Explorer into the application.

I've tried running Windows Explorer as administrator, but to no avail.

Is there a way to get drag and drop to work when my applications are under "Run as Administrator"?

  • 2
    Eureka! So that was the cause. – MC Emperor Jun 1 '15 at 12:17

The problem is tied to how security permissions work. The ability to drag and drop from a normal applications to an elevated one would break the security model behind UAC. However, I'm unclear as to why a UAC prompt isn't shown, thus allowing for a temporary elevated operation (much like any linux user experiences every day). This is definitely something that Microsoft needs to work on. What troubles me is that this problem is already old. Vista behaved the same.

There's 2 things you can do (one ugly, one annoying)

  • Ugly: Disable UAC. But you lose all the extra security it offers.
  • Annoying: Use another File manager and run it too as an Administrator

Why another file manager? Because you can't actually elevate Windows Explorer. Despite seeing the option in the context menu of the Windows Explorer icon and a UAC prompt being displayed, the fact is Windows Explorer will not be elevated.

  • 12
    Actually it can. If you selected the option Launch folder windows in a separate process and close all your folder windows, then the next one you launch the Run as Administrator option will work. Until all folder windows are closed, all folder windows will then be elevated. – Michael Urman Oct 23 '09 at 1:45
  • This is interesting, but how come it doesn't fix the drag and drop issue? – Chris Oct 23 '09 at 18:11
  • What doesn't Chris? My answer or Micheal comment? – A Dwarf Oct 23 '09 at 18:14
  • 1
    @Michael, under Windows-7 that doesn't work. Explorer can never be elevated to my knowledge. – A Dwarf Oct 23 '09 at 18:16
  • 2
    I ran 7-Zip with admin privileges and was able to drag a file from that app to another app with admin privileges. – KClough Nov 26 '09 at 19:11

This is a workaround according to ADwarf "Annoying" solution: open Notepad with "Run as Administrator". Click on open in file menu and enter * in file name and press enter. Now you can drag files from there to your app. Notepad open browser doesn't support multiply file selection, but you can use other programs in the same way to use drag and drop!

  • I do wonder what's more annoying: going through this every morning, keeping notepad open and navigating to the folder you need every single time followed by a drag-and-drop operation, or clicking "Open" in the target program, navigating to the folder you need and than just double-clicking it. In every way you put it, it's a major PITA! – Grimace of Despair Jul 22 '13 at 14:18

Windows 7:

Launch PowerShell using Run As Administrator


taskkill /f /im explorer.exe

start-process explorer.exe

or launch cmd (Command Prompt) using Run As Administrator


taskkill /f /im explorer.exe

start explorer.exe

All your new Explorer windows will now be elevated and you can drag and drop from them into other elevated applications. I tested and verified this prior to posting.

  • 3
    This doesn't work. Tried it and still the same issue. – Thierry Jan 6 '14 at 17:37
  • This worked for me. Thanks! I'm on Windows 8, dealing with dragging and dropping to an app that was spawned by Visual Studio 2013 (which is running as admin). – Owen Feb 6 '15 at 17:15
  • Do you recommend this to be run automated at startup? – Oliver M Grech May 23 '17 at 17:56

There was an update to Visual Studio 2005 published 2 years ago that fixed many UAC problems on Vista, and that same update fixes the same problems on Windows 7.

It is not a critical update so you wouldn’t get it automatically, and it was not included with VS2005 SP1. They’re not actively publicizing this update now b/c they just want everyone to go to VS2008. So chances are you don't have it.

Explanation at http://msdn.microsoft.com/en-us/vstudio/aa948853.aspx?lcid=1033

Download at http://www.microsoft.com/downloads/details.aspx?FamilyID=90e2942d-3ad1-4873-a2ee-4acc0aace5b6&displaylang=en

Here's what that update fixes, when running Visual Studio in normal user mode with UAC turned on:

  • Drag/drop files from an explorer window
  • Launching VS (as a normal user) by launching shortcuts to solutions/projects or associated file types
  • DLL/EXE registrations still fail (rightly so, since those are system-level changes.)

If you're running VS as an administrator, the window is still locked down to drag/drop and shortcuts, and DLL/EXE registrations work correctly without having to completely turn off UAC.

Note: VS will still warn you about administrator mode when you launch it, but now you can probably ignore that warning permanently.

  • But this is for VS 2005...? – Chris Aug 31 '10 at 22:15
  • Yes, VS 2005. Sorry I wasn't clear. I updated my original post with more information. – John M. Black Sep 1 '10 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.