UPDATE: Please check out the new answer I've posted to this problem. It might be that a solution to this frustrating problem exists now. Scroll down to see it.

Quite a while ago my graphic card died and I had to buy a new one. I decided for an ASUS Radeon HD 7870.

While I love the power of the graphic card and have no problems while playing games, I'm experiencing an annoying problem while I'm just on Windows with my dual monitor setup. Sometimes my mouse cursor gets broken on my main monitor and simply looks like this:


This seems to happen just at random situations and also sometimes when I move the mouse from one monitor to the other one. I can also always use a "workaround" to "fix" the problem, which means if I just move the mouse from one monitor to the other one often enough it becomes normal again at some point. But I don't want to do this all the time, so I'm searching for a solution.

I did a lot of Google research (try typing "ATI brok" in Google and it will already show you a lot of search entries for a broken Cursor), but the results where mostly not helping at all. Often they are "old" (from 2009 and before) and deal with mouse problems while playing games, which is not my problem. I'm missing up to date results from someone with maybe the same graphic card and can help me.

What I read some times is that deactivating windows aero should "fix" the problem, but to be honest I enjoy Windows Aero a lot and would prefer something different (I don't want to sound arrogant). The same is that some people say it would help to activate mouse trails, but the look & feel (like lagging) then bothers me even more. I also tried to disallow that the mouse cursor gets changed through designs, but this didn't change anything

Here is for example a big thread where people are talking about a similar (same?) problem. Some also state that deactivating Catalst AI would solve it for them, but I can't find this option in my up to date Catalyst Control Center anymore (maybe possible in a file somewhere in the directory of the CCC?).

Well, what's left to say is that I always keep my system up to date and already often installed new graphic card drivers (even sometimes tried Beta Versions). But the problem never disappeared.

Can someone here help me, has some ideas or experienced the same? I would be glad to hear from you! I'm also curious if this could maybe mean my graphic card is broken? (Although somehow it's hard to imagine for me)

Thanks a lot for every thought you're sharing with me.

Edit: Today it has happened again with the new ATI drivers.

Edit 2: Please check out the new answer I've posted to this problem. It might be that a solution to this frustrating problem exists now. Scroll down to see it.

  • try the 13.5 beta driver: support.amd.com/us/kbarticles/Pages/…. Also try to disable the mosue shadow as suggested in the technet topic Commented May 4, 2013 at 18:58
  • You are not alone in this! I've experienced this first time about 5 years ago on my laptop with ATI 2600 HD graphics. It happens only sometimes (sometimes after playing Global Operations) and I was not able to find any solution. Same as you with dual monitor setup and that time I was using Win Vista x64. Now I have Win 8 x64, dual monitor setup, Sapphire Radeon HD 7870 XT (this version has Tahiti GPU from 7900 series) and recently I have seen this "half-tree" again! This time it happens without any game involved...
    – Juraj
    Commented May 4, 2013 at 20:21
  • But in my case I'm experiencing also some artifacts in Firefox but it's very rarely and it involves placing (or moving) cursor on some specific places on page. I think this all is caused by malfunctioning graphics RAM but I cannot prove it. BTW everything else is working just fine – OpenCL programs, games, video playback... So as you can see, this problem is very old and I believe it's only ATI/AMD specific. The worst thing is that I cannot reproduce this problem... it just happens.
    – Juraj
    Commented May 4, 2013 at 20:21
  • tried disabling the mouse shadow, but it didn't help. I today installed 13.4 and the issue occured again. I think I will give the new 13.5 driver a try, although I'm not very optimistic. Thanks for your comment
    – Waylander
    Commented May 4, 2013 at 20:44
  • I get broken mouse cursor after SimCity 5, with all ATI drivers I tried. My workaround is to SLEEP Windows. HW: Radeon 5770, Win 7x64.
    – Hernán
    Commented Mar 10, 2014 at 18:37

7 Answers 7


ATI drivers had mouse corruption errors since 2001.
You have already discovered almost all the existing workarounds.

You should contact their Support, and in the meantime keep on looking for driver updates. But I don't think that a 12-year problem has any hope of an early solution.

Below is the complete list of workarounds that I was able to find :

  • Enabling/disabling shadows for mouse
  • Enabling mouse trails
  • Disable Catalyst AI (through ATI Tray Tools)
  • Disable mouse shadow
  • Disable Windows Aero
  • Use a third-party cursor app (cursorFX, etc.) to draw a better cursor
  • Return the DPI setting in Windows 7 to normal (if changed)
  • Change the dual monitors positioning in Windows (use Above etc.)
  • Do not use ATI for multiple monitors
  • Move mouse to lower right corner, completely
  • Move mouse right under a taskbar item (lower most), and shake it left and right

And here's a possible list of ways to "fix" the cursor without rebooting:

  • Unplugging mouse
  • Open magnifier and zoom to 100%, leaving the magnifier open
  • Activating an eyefinity profile (for those with multiple screens)
  • Changing resolution
  • Put Windows into sleep mode
  • As soon as you see the stripes/comb pointer, move the mouse to the edge of your screen (top right was mentioned) and shake the mouse a few times
  • Thanks a lot for your answer. I will check out if disabling Catalyst AI or using a third-party cursor app will fix the problem for me (mouse shadows sadly didn't). Do you have any suggestion on how I should disable Catalyst AI, since the option is gone in nowadays CCC?
    – Waylander
    Commented May 6, 2013 at 22:59
  • Here is a link on How to disable Catalyst AI with the latest CCC.
    – harrymc
    Commented May 7, 2013 at 6:27
  • Thanks a lot for the link. So you would say this is definately (!) no hardware issue, so my graphic card itself is not broken?
    – Waylander
    Commented May 11, 2013 at 23:06
  • I can't of course be definitive, but the general consensus on the Internet seems to be that ATI cards are good to excellent, and it's the software that's broken. (I myself prefer Nvidia, hardware and software.)
    – harrymc
    Commented May 12, 2013 at 6:43
  • I did take care, thanks a lot for the time you spent on this and the answers you gave :-)
    – Waylander
    Commented May 12, 2013 at 11:25

I've tried everything to fix this, and recently i found out the best way to fix it (Which hasn't failed at all so far) is to move the mouse to the top right of my screen and shake it around a bit. I'm so relieved i found this solution, I use 3 external monitors 7970M graphics card and moving the mouse to the top right then shaking it around would make it jump from my 2nd to 3rd monitor, after about 5 seconds at most of doing it the mouse fixes itself.

  • Wow, thanks for this one, the only one that worked!
    – cabecao
    Commented Apr 25, 2014 at 11:50
  • Worked for me too! Really weird fix
    – Steven
    Commented May 20, 2015 at 6:09
  • IT WORKED :) lol Commented Jun 8, 2015 at 9:30
  • Works like a charm. Note that the key is not necessarily to move it to the top right corner, but to the corner where the mouse jumps between two monitors. For those of you whose main monitor is not on the left, like me, that could be the top left corner. Commented Nov 26, 2015 at 5:29

UPDATE: It seems for me that the new AMD beta drivers (version 14.6, downloadable here) fixes the problem. At least for me. I downloaded them one week ago when I still had mouse corruption issues with the older driver and now they're gone (For the first time since I bought this graphic card).

I recommend everyone with an AMD card to check them out and see if it fixes your problem!

  • Wondering if this fixed your problem for good? My suspicion is that when you updated the driver, that in itself fixed it just by resetting the driver (similar to how rebooting also fixes it).
    – Jerad Rose
    Commented Mar 27, 2015 at 23:56
  • It fixed it in a way that it does not appear for me at all anymore. I tried every released (also beta) driver and the problem always occured again after some time but since 14.6 it's gone for me.
    – Waylander
    Commented Mar 29, 2015 at 14:32
  • I came here because I just had the problem again. So no, not fixed. But it is and has always been rare for me. Like once a month or so ... I bet no one at ATI has a clue what is causing this. :-)
    – Mantriur
    Commented May 3, 2015 at 16:22
  • 1
    It's 2016-10-02, new video card latest gen, same problem. Corrupted cursor.
    – oxygen
    Commented Oct 2, 2016 at 20:49

If you're using multiple monitors you can always right click on the desktop of your side monitor(s) and the main display will be corrected again. Annoying bug but that's always fixed it for me when it appears.

Drivers will not just fix this one, I haven't had it until the 7000 series though which is extra annoying and I've been with ATI / AMD after 3DFX went out.


Simplest and least invasive solution.

Open the "Screen Resolution" context menu by right clicking on the Desktop.

Reorder any display and apply changes. Reorder displays back to original order and apply changes.

Viola! Your cursor is back.

  • Didn't work for me, but changing "Extend displays" to "Duplicate" and back solved the problem.
    – bretik
    Commented Dec 15, 2015 at 10:17

Open a window, hover mouse over minimize, expand, close, area at the top right and it will go back to normal, or at least it does for me, hope this helps.


At the time of writing this post and app (2016-10-02), with a new generation (launched 2 months ago) ATI card and using the latest drivers, the mouse cursor corruption is still here, and is happening (at least to me) during every single Starcraft 2 game, randomly, sometimes during intense battles.

I have decided to automate the mouse trails enabling workaround fix provided in @harrymc's answer.

So here it is (works for me!):

Fix corrupted mouse cursor app

Contributions and issue reports are welcome: GitHub project page

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .