Almost every file I download is corrupted. I have to use my second computer on the same network to download my drivers to install.

At first I thought it was my Intel SSD, so I removed it and tried running on my spare harddisk. Didn't help.

Then I tried running memtest86+ v2 and no errors were reported. (I'm downloading Ubuntu now using my second computer to run an updated version of memtest)

I've ran chkdsk /F on the harddisk and no errors were found. On my SSD, I did a secure wipe and some tests using Intel's SSD tools and no errors were found.

My Chrome browser keeps crashing, so I thought it could be my graphics card since Chrome uses hardware acceleration right? So I bought a new graphics card and still there are errors.

I manged to get my MMO installed and I don't seem to have any problems running it.

So my final guess is either my CPU or motherboard is dying.

Are there any other tests I can do to find out the problem?

Update: The computer with the problem is connected to my router using an ethernet cable, I just changed this cable a few months ago.

I shared the folder with the downloaded drivers on my second computer using Windows 7's homegroup, and installed it from there so I think the network is working fine.

Update 2: When I downloaded my graphics drivers and tried to install them, it says something about the file being corrupted, and I need to download again. It happened for my graphics drivers, a game patch, chrome installation file, and maybe the windows update files because I got a blue screen during the windows update. Something about the ntfs.sys file.

When I reboot, I couldn't boot into the OS because of a BSOD with the error "Page fault in non paged area". I had to go into repair mode and do a system restore before everything went back to normal.

Update 3: I ran Memtest86+ v4.2 for 8 hours, 4 passes, 0 errors.

Update 4: I ran OCCT, CPU:OCCT test and it reported an "error on Core #3". I disabled it in BIOS and ran the test again, this time it just says "error detected". I suppose my CPU's causing the corruption problems.

  • 2
    what are you downloading these over? Have you tried another browser? When you download ubuntu, do these downloads work ok? – Journeyman Geek May 4 '13 at 11:34
  • I'm using a wired connection. I've tried Internet Explorer and the downloads are corrupted too. I'm using another computer to download Ubuntu – wyred May 4 '13 at 11:42
  • How are you checking that they are corrupted? – TessellatingHeckler May 4 '13 at 11:55
  • I've updated my main question with the answer – wyred May 4 '13 at 12:11
  • 1
    Does it happen also after fresh boot of the (cold) computer or after some work? You can use Orthos to stress the CPU (several kinds of tests available), HWMonitor to monitor temperatures of hardware. Also, have you checked your system with antivirus etc.? – jakub.g May 11 '13 at 19:03

The problem was found to be the CPU or maybe the motherboard, as I don't have a spare motherboard to test. Thanks for all the help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.