I've been unable to start my Windows Firewall service for a while now. How can I get it to start?

When I try through the Services manager (services.msc) I get this error:

enter image description here

I am running services.msc as administrator.

The Event Viewer show this error message:

The Windows Firewall service terminated with service-specific error Access is denied..

The current logon credentials are:

enter image description here

I've tried Local system account and get the following error:

enter image description here

I have run the System File checker tool (SFC.exe) but found no problems.

Windows Resource Protection did not find any integrity violations.

I got an error trying to run the FixIt on the following page:


Which claims to do this:

What it fixes...

  • Windows Firewall is not the default firewall
  • Windows Firewall does not start
  • Windows could not start Windows Firewall. Service-specific error 5 (0x5)
  • Remote Assistance is not working because it is blocked by Windows Firewall
  • You cannot access shared files and printers because sharing is blocked by Windows Firewall
  • BFE service is missing
  • Firewall will not start Error Code 80070424

The error I got was:

enter image description here

I have even reset the security on the service to what it should be after building the OS by following these instructions:

Part 1: Creating the policy template.

  1. Open a command prompt.
  2. Run mmc.exe.
  3. File menu > Add/remove snap-in > Security Templates > Add button > OK button.
  4. Right-click on the Security Templates > New Template Search Path > Select C:\Windows\Security\Templates as the destination.
  5. Right-click the C:\Windows\Security\Templates directory > New Template > specify the name as Server 2008 Firewall > OK button.
  6. Expand the Server 2008 Firewall node > click on the System Services node.
  7. Right-click the Windows Firewall service > Properties.
  8. Put a check in the "Define this policy" checkbox.
  9. Select the Automatic radio button.
  10. Select the Edit Security button.
  11. Ensure the following entries are listed. If they aren't, then add them:
    • SYSTEM: Full Control
    • Administrators: Full Control
  12. Click OK, and OK again to close the Windows Firewall Properties dialog window.
  13. Right-click on the Server 2008 Firewall node again on the left-hand side, and choose Save.

Part 2: Applying the template security.

  1. In the same mmc, select the File manu > Add/remove snap-in > Security and Configuration Analysis > Add button > OK button.
  2. Right-click the Security Configuration Node > Open Databse (think of this as Create Database).
  3. Specify a database name > Open button.
  4. In the Template window, open the C:\Windows\Security\Templates\Server 2008 Firewall.inf.
  5. Right-click on the Security Configuration node > Configure Computer Now.

Well, as no-one has (can?) answer this - I'll post what I did to work around the issue.

Restored to an image I took just over a year ago. Problem solved, kinda.


This may be caused because the “NT Service\MpsSvc” account does not have adequate permissions on the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess

Detailed solution:

  • Browse to the key in Registry Editor (as administrator).
  • Right click SharedAccess, and click Permissions.
  • Click Add.
  • In the “Enter the object names to select” field, type NT SERVICE\mpssvc (case-insensitive).
  • Then click Check Names. The name should change to MpsSvc.
  • Click OK.
  • Select “Full Control” in the “Allow” column.
  • Click OK.

I encountered this problem on Server 2012 R2 today, and got the above fix from a thread on Microsoft Community. It worked like a charm for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.