I'm trying to enable BitLocker on a 4TB drive with 4K physical sectors (Advanced Format) on a 64-bit Windows 7 box with SP1.

The drive is partitioned GPT (1 partition using all of the available space) and formatted with NTFS.

When I right click on the drive and select 'Turn on BitLocker...', a dialog appears that says 'Staring BitLocker' and 'Please wait while BitLocker initializes the drive'. There is also a warning (same dialog) that says 'A device attached to the system is not functioning.' The progress bar never moves and there is no disk or CPU activity. I'm not seeing anything in the event viewer, either.

How do I get BitLocker turned on for this drive?

The drive is is a 4TB Hitachi DeskStar 7K4000 in an internal bay connected via SATA-II (host has no SATA-III ports). It's not a boot drive. I'm creating a single GPT partition (using the whole drive). The motherboard has an Intel P55 chipset with no TPM. No yellow exclamation marks in Device Manager. I've waited over an an hour, nothing happens with the dialog box. The drive has 4K physical sectors, 512 byte logical sectors (it's Advanced Format 512e/512 emulation, not 4Kn/4K Native).

When I formatted the volume, I left the allocation unit size at 'Default', which ended up being 4k. Is there some requirement for a different allocation unit size for volumes over a certain threshold size?

It seems that I can create a smaller partition (2TB) and there is no problem. It seems that the magic limit is 3815174 MB, which is a 144 MB less than the available capacity of 3815318 (according to the New Simple Volume Wizard). Can anybody explain that? I updated the motherboard BIOS to the latest version, that seems to have had no effect on this issue.

I want to know why I Bitlocker fails to encrypt a single partition using all of the available space (according to the 'New Simple Volume Wizard), but will encrypt a partition 144 MB smaller? I have 2TB Hitachi drives with a single partition, no unallocated space and they encrypted just fine. According to the Disk Management snap-in in the Microsoft Management Console, I have 145 MB of unallocated space on the 4TB Hitachi. A way to avoid wasting the 145 MB would be nice. It's not a lot of space, but I don't want to screw around with finding the magic number again on a different 4TB drive.

I just tried to encrypt a 3815318 MB single volume on the drive with the manage-bde command line tool:

manage-bde -on X: -RecoveryPassword

I get this:

Volume X: [New Volume]
[Data Volume]
Key Protectors Added:

ERROR: An error occurred (code 0X8007001f):
A device attached to the system is not functioning.
  • "The progress bar never moves" -- Exactly how long did you wait? Does your system have a TPM chip? – Ƭᴇcʜιᴇ007 May 5 '13 at 14:35
  • How is the drive connected? Internal SATA, eSATA, USB? (Asking because "device attached is not functioning" troubleshooting would vary.) – MikeBaz - MSFT May 5 '13 at 14:41
  • thanks for that - two follow-ups: (1) does Device Manager show any devices with the yellow exclamation mark or does the System log give a hint as to what device it's complaining about? (2) found a ref online to someone seeing this when they had a SATA cable on another port with no drive on the cable at the other end - is that true in this case? – MikeBaz - MSFT May 5 '13 at 14:54
  • @MarkJohnson then unfortunately I don't have anything else for you other than "4K AF drives are funky under Win7" which while true and documented, doesn't help you any. I can't find anything about BL specifically in this scenario. – MikeBaz - MSFT May 5 '13 at 15:17
  • @MarkJohnson well that is very interesting. That feels like something you should post as an answer to your own question once it's old enough to do that :) – MikeBaz - MSFT May 5 '13 at 16:09

A MUCH easier solution. After formatting the drive, copy some data to it before turning on BitLocker. I did this for a WD 4TB drive and now everything is working fine. I copied a folder that is under 2GB with about 650 files and now BitLocker is running.

  • +1 This worked perfectly for me on a 4 TB Toshiba Canvio. My symptoms exactly matched the original post. I did a backup to the drive before finding this page. When I tried to turn on Bitlocker after the backup, it worked perfectly. – Adrian McCarthy Jan 26 '15 at 13:40
  • Doesn't work for me unfortunately. – tbone Jan 14 '17 at 19:39

Manufacturers will commonly state a formatted capacity, but due to the different way operating systems interpret byte sizes, and the amount of physical sectors on a drive, this value can vary. The true size of a drive is dependent on the number of physical sectors (and the size of these sectors).

For example, a Western Digital WD4001FAEX has 7,814,037,168 sectors, each which is 512 bytes in size. Multiplying the number of sectors by the size per sector, we obtain:

7,814,037,168 sectors * 512 bytes/sector = 4.00078703 x 10^12 bytes

Using base 1000 units (e.g. 1000 bytes = 1 kB), this would be converted to megabytes as:

4.00078703 x 10^12 bytes / (1000x1000 MB/byte)  ~= 4,000,787 MB

However, Windows interprets disk sizes in bases of 1024 and not 1000 (e.g. 1 kB/kilobyte is not interpreted as 1000 bytes in Windows, it is interpreted as 1 kibibyte/KiB or 1024 bytes) on Windows, and thus the maximum size Windows would report (ignoring any filesystem overhead) in mebibytes is:

4.00078703 x 10^12 bytes / (1024x1024 MiB/byte) ~= 3,815,448 MiB

This is very close to your reported formatted capacity (3,815,174 MiB). It's likely the remaining ~300 MiB is consumed by the filesystem itself, which is also likely formatted as NTFS. NTFS is a journaled filesystem which requires additional information to be stored (like the master file table, and several other hidden metafiles).

  • Seems I should have fully read your answer before I made a fool of myself. I see you did address the reason his solution was required. – Ramhound May 25 '13 at 5:09

The easiest way to get around this to reduce your drive by 15 GB. If you do so the message should go away. I don't have a good explanation for why this is, but it has worked for me on 2 diff 4TB drives. I hate giving up the 15 gb (x2 drives) but it is a small percentage of the drive to have it use bitlocker.

  • I believe that the amount of the required free space at the end of the disk is only about 1 MB. – harrymc May 29 '13 at 11:43
  • @MarkJohnson: You thought you did, but Windows stole 1MB from your disk. Probably the space required for 4TB is at least twice larger than for 2TB and Windows for some reason cannot manage to reduce the partition's size. Probably this is a bug in Windows. – harrymc Jun 3 '13 at 11:15

The solution is: Uninstall KB2799926. It seems that KB2799926 is a fix for Bitlocker To Go. Uninstalling may break Bitlocker To Go, so you may just want to live with the unallocated space. Or just reinstall the fix after the drive is encrypted. That works, too.

Not the answer you're looking for? Browse other questions tagged or ask your own question.