16

I'm not sure where the problem lies, as for the page I am developing I can't remember giving a "no" to geospatial information, but through whatever means I have a Chrome installation that is acting on a refusal to share geospatial information.

How can I clear Chrome's memory that I at some point rejected permission to geospatial information? Will some form of "clear browser data" give me a fresh slate?

Thanks,

16
  • Click the Chrome menu Chrome menu on the browser toolbar.

  • Select Settings.

  • Click Show advanced settings.

  • In the "Privacy" section, click Content settings.

  • In the dialog that appears, scroll down to the "Location" section.

  • Click Manage exceptions.

Source: http://support.google.com/chrome/bin/answer.py?hl=en&answer=142065

Also be sure to check all other Privacy and Content settings for default behavior.

| improve this answer | |
  • 1
    And your response didn't just provide the option of clearing a setting; it also let me see that I had provided geolocation to the site in question. – Christos Hayward May 5 '13 at 15:52
  • 1
    For information, when you use Chrome for Android, you have to open Chrome's menu, tap "Settings", "Content settings", "Web sites settings", then search for the website in the list and tap to open it, then finally check or uncheck "Access to my position". If you want Chrome to forget a "no", you have to check and uncheck it, which will cause Chrome to remove the saved decision (the site doesn't appear in the list anymore). – pomeh Sep 17 '14 at 12:45
  • TLDR: Paste chrome://settings/content/location in address bar, then follow last step in above list – riper Apr 29 '18 at 10:36
16

You can probably just change your setting by clicking the site icon:

enter image description here

| improve this answer | |
2

If previous answers don't solve your problem, is possible you were using Chrome 50+ on a HTTP not secure domain. This article explains why Chrome fails while detecting geolocation and how to detect when this is happening: https://developers.google.com/web/updates/2016/04/geolocation-on-secure-contexts-only

navigator.geolocation.getCurrentPosition(function(success) { /* Do some magic. */ },
  function(failure) {
    if(failure.message.indexOf("Only secure origins are allowed") == 0) {
      // Chrome 50+, no HTTP domain.
    }
  };
});
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.