1

At times when I boot my computer, my external hard drives will indicate disk activity before Grub loads. At this stage when the external drives blink, there is a blinking underscore displayed on the monitor so I'm guessing GRUB does this. The process can be quite slow as I have an external hard drive that spins down after no hard disk activity.

If this process is mandatory in order to identify bootable devices, is there a way to blacklist my external hard disk? Perhaps my external hard drive accidently has bootloader code and is prompted grub to further identify any potential operating systems?

3
  • 1
    I'm not 100% certain, but I'm going to guess the drive activity you're seeing is actually happening before the bootloader even runs . . . grub doesn't scan devices, it just shows what's in it's conf file
    – ernie
    May 6 '13 at 3:10
  • Ernie has a point... The BIOS attempts to look for devices before the bootloader even starts. May 6 '13 at 3:11
  • Oh man, I'm so stupid. Should this question even be deleted?
    – chaz
    May 6 '13 at 3:22
2

The easiest thing to do would be changing the boot order in BIOS. Change the boot order to:
- Internal drive
- External drive (USB)
- etc
If your internal drive is the first one to boot and you still have this problem, you will know the external drive is not creating this problem.

2
  • Thanks, I cannot believe I did not consider that. That solves my problem, thanks!
    – chaz
    May 6 '13 at 3:21
  • 1
    A small tip for future readers - there are some strange BIOSes that allow the boot order menu to be overridden with a separate option like "always boot from USB devices first". Just something to keep in mind if you end up with a BIOS like that.
    – Karan
    May 7 '13 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.