On my Mac with OS X Snow Leopard, I continually get "Server Not Found" errors on my web browser (Firefox) while browsing various web sites. In attempts to resolve the problem I've tried the following (each, more than once):

I can't find what is causing the problem or a different way to resolve it. I have several computers on the router and I don't get this problem with them.

In some cases, only part of the page will load. Graphics might be missing or ads don't load. I'm almost sure it has something to do with DNS but I'm not sure if it might be the Mac or if it is something with the router.

Any thoughts would be appreciated. I'll try any reasonable suggestions...

Update: In response to a request for example sites:

  • www.python.org - I noticed it a lot here but I follow a lot of hyperlinks
  • Stackoverflow.com
  • Google.com
  • Weather.com
  • Gmail.com
  • Wikipedia.org
  • My Graduate Schools' sites

It occurs intermittently and I know that it isn't the site because I can quickly access the site on my other computers. Also, if I refresh enough -- 3 to 4 times --, it will usually pull up the site.

Update: Based on feedback thus far, I tried dig. I was having trouble with Ubuntu.com so I ran the dig on that. Here are the results:

frank-villasenors-macbook:Documents FrankV$ dig www.ubuntu.com

; <<>> DiG 9.6.0-APPLE-P2 <<>> www.ubuntu.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 60666
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;www.ubuntu.com.            IN  A

www.ubuntu.com.     432 IN  A

;; Query time: 24 msec
;; WHEN: Tue Oct 27 18:31:33 2009
;; MSG SIZE  rcvd: 48

I than ran one on a web site that was working (my blog) and here are the results:

frank-villasenors-macbook:mozilla-central-working FrankV$ dig www.theopensourceu.com

; <<>> DiG 9.6.0-APPLE-P2 <<>> www.theopensourceu.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37084
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

;www.theopensourceu.com.        IN  A

www.theopensourceu.com. 3600    IN  CNAME   theopensourceu.com.
theopensourceu.com. 3148    IN  A

;; Query time: 98 msec
;; WHEN: Tue Oct 27 18:33:40 2009
;; MSG SIZE  rcvd: 70

They look similar; I don't think this is telling me anything (right now)... Just before submitting this, I refreshed my Ubuntu.com window and the site came up... Perhaps the dig fixed it?

Update (11/17/2009): I'm still having trouble with this here and there. One additional thing I've noticed is that sometimes the DNS lookups simply take longer than I would expect. For example, if I attempt to go to Superuser.com the web browser (I generally use FireFox) will show the loading screen for 30 to 45 seconds. It could be longer and it could be shorter but at that point sometimes the site eventually loads and sometimes I receive the aforementioned error message.

In case there is question, I have a broadband internet connection (by Comcast in Chicagoland) which generally reports speeds of around 5mbps. Again, I only see this issue on the MacBook. I also have two Vista based computers and a Ubuntu based computer which do not present this problem.

  • 1
    For reference Snow Leopard doesn't store the DNS cache used by most programs anymore in Directory Services but instead stores it using mDNSResponder. To reset the DNS cache it's most easily done by running sudo killall -HUP mDNSResponder
    – Chealion
    Oct 23, 2009 at 3:38
  • Could it simply be that the server(s) you are trying to reach are actually flakey? Or that your connection to the net is actually fluctuating? Can you give us an example site? Oct 23, 2009 at 7:37
  • Perhaps the sudo killall -HUP mDNSResponder was the detail that I was missing. I'm keeping an eye out for the issue and will attempt this if it occurs (assuming I can get to this site) :-)
    – Frank V
    Oct 23, 2009 at 16:12

6 Answers 6


In Firefox, "Server not found" tells you it does not know its IP address. So, DNS problems indeed.

When you encounter this problem again you can immediately try to see if other DNS servers would give different results. So, do not refresh your browser, do not flush the cache, but run the following (like you already did) to tell you what your current DNS server knows about the troublesome domain. When you get an answer for the following then the test kind of failed, but maybe the following does not give you a useful reply at all:

dig www.python.org

  www.python.org.  33592 IN A
  ;; Query time: 168 msec
  ;; WHEN: Sat Nov 14 12:56:54 2009

The above results might have been cached by your router/modem, or were delegated to your ISP's DNS server for anything the router did not yet know. The value for Query time might be some indication if the result was cached in the modem/router or not. So, run that very same command again (press arrow-up and Return in Terminal):

  ;; Query time: 33 msec
  ;; WHEN: Sat Nov 14 12:57:14 2009

Above, seeing 168 versus 33 milliseconds, we can assume that the result for the first dig command was not cached in the modem/router, and asking the provider's DNS server took some extra time. The second request probably was cached.

If the query times differ a lot for you as well, then for some reason your browser or OS had not requested that domain from the DNS yet, even though your browser was trying to show that page. That would probably tell you the computer's DNS is messed up (which makes sense, as other computers using the same modem/router do not suffer the same issue).

Next, check if, for example, OpenDNS yields other results:

dig @ www.python.org

  www.python.org.  83166 IN A

Above, the results are the same, but your mileage may vary. (You only need to compare IP addresses; when explicitly using some DNS server, like by using @, then the query times will not be much different for repeated requests.)

So, whenever this happens again: let us know the results of the above? Alternatively, just set up your Mac to use the OpenDNS servers for a while, and see if the problem still occurs then?

† Non-responding servers would give you "The connection has timed out", and it probably takes much longer to show that error.

  • Created an account just to upvote you on this :)
    – Spike
    Apr 16, 2011 at 20:23

I fix this issue by setting network.dns.disablePrefetch to true


  • 1
    Link answers are generally discouraged. Try to include the relevant information from the website in your answer. That way if the link changes or goes down, the answer is still relevant. Nov 18, 2014 at 19:45
  • 1
    Can you give a more detailed description of the linked content, and explain how it relates to the question? This will help ensure that this answer remains useful in the event the link becomes invalid.
    – bwDraco
    Nov 18, 2014 at 22:52

This is a know issue, there is a bug in mDNSResponder (there are plenty of posts in discussions.apple.com), some others already opened a bug in Apple, we don't know if they will deliver it in 10.6.3, as this bug is not massive, but depends on the ISP's DNS server (even if you set the OpenDNS servers, it will not change the situation, as a second bug in mDNSResponder mess up with the order of DNS servers it has in list, and even if you "force" it to use the OpenDNS, it will get the one "offered" by the default gateway, which is the one provided by your ISP, which is the one matching with the first bug). I have the some problem and there is no solution at the moment, downgrade to Leopard or wait for 10.6.3 (...or ask your ISP to change/update their DNS Server)...

Another alternative is to create "in LAN" a proxy... in that way it should work (it seems for someone, as you will see from the posts in discussions...). I'll wait 10.6.3 even if I'm not sure they will fix it 100%, are a couple of tricky bugs and not easy to replicate and solve.

bye gpy


Have you tried using dig hostname.com from the command line while experiencing the problem? This will try to do a lookup for you and may reveal more information about the problem.

What DNS servers are you using? Are all your systems using the same ones?

Are you using your ISP's DNS servers? Typically these will get overloaded by requests. I you are skilled enough I recommend setting up a local caching nameserver (not OpenDNS as some may suggest -- they play games with DNS that they shouldn't).

Have you tried going to a different system while experiencing this and reloading two systems at the same time, just to be sure it isn't intermittent?

  • I have not tried dig but I will keep that in mind. I'm not sure about the DNS Servers. It should be the standard for my router or cable internet - Comcast. I don't consider myself an internet "superuser". I'm a software engineer so I know computers better than some but I'm not an expert (and acknowledge it.). And yes, the sites generally work from other computers. I've isolated the problem to my MacBook - Either a setting or simple connectivity. Though, I've never have internal networking issues with the computer so I think it has something to do with DNS.
    – Frank V
    Oct 23, 2009 at 16:16

Whether right or not, I ended up replacing my wireless router. It seems to have resolved the issue.


I'm having the same problem on my Snow Leopard macbook (10.6.8). Occasionally Firefox can't find the server, nor can ping, but nslookup resolves the IP. I only recall having the issue with en.wikipedia.org.

Here's something that worked 2 or 3 times for me so far for en.wikipedia.org: Visit www.wikipedia.org and click on "English" which takes you to en.wikipedia.org. This makes the host "reappear" immediately. (Before I tried this, it would take about a minute for the host to be recognized again.)

I tried a similar workaround by google'ing for the site and clicking the link from the search results, but it didn't work. Maybe it's related to a cache being cleared only when another host on the same domain is accessed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.