1

In older versions of Notepad++ under the run menu there were options such as "Internet Explorer" and "Firefox" that when clicked opened the current script/HTML in the web browser. How do you get it back? I tried Run->Run->selecting FireFox.exe->Save As but when I try to use it nothing happens.

I'm using version 6.3.2

Here is Notepad++\shortcuts.xml

- <NotepadPlus>
  <InternalCommands /> 
- <Macros>
- <Macro name="Trim Trailing and save" Ctrl="no" Alt="yes" Shift="yes" Key="83">
  <Action type="2" message="0" wParam="42024" lParam="0" sParam="" /> 
  <Action type="2" message="0" wParam="41006" lParam="0" sParam="" /> 
  </Macro>
  </Macros>
- <UserDefinedCommands>
  <Command name="Launch in Firefox" Ctrl="yes" Alt="yes" Shift="yes" Key="88">firefox "$(FULL_CURRENT_PATH)"</Command> 
  <Command name="Launch in IE" Ctrl="yes" Alt="yes" Shift="yes" Key="73">iexplore "$(FULL_CURRENT_PATH)"</Command> 
  <Command name="Launch in Chrome" Ctrl="yes" Alt="yes" Shift="yes" Key="82">chrome "$(FULL_CURRENT_PATH)"</Command> 
  <Command name="Launch in Safari" Ctrl="yes" Alt="yes" Shift="yes" Key="70">safari "$(FULL_CURRENT_PATH)"</Command> 
  <Command name="Get php help" Ctrl="no" Alt="yes" Shift="no" Key="112">http://www.php.net/%20$(CURRENT_WORD)</Command> 
  <Command name="Google Search" Ctrl="no" Alt="yes" Shift="no" Key="113">http://www.google.com/search?q=$(CURRENT_WORD)</Command> 
  <Command name="Wikipedia Search" Ctrl="no" Alt="yes" Shift="no" Key="114">http://en.wikipedia.org/wiki/Special:Search?search=$(CURRENT_WORD)</Command> 
  <Command name="Open file" Ctrl="no" Alt="yes" Shift="no" Key="116">$(NPP_DIRECTORY)\notepad++.exe $(CURRENT_WORD)</Command> 
  <Command name="Open in another instance" Ctrl="no" Alt="yes" Shift="no" Key="117">$(NPP_DIRECTORY)\notepad++.exe $(CURRENT_WORD) -nosession -multiInst</Command> 
  <Command name="Open containing folder" Ctrl="no" Alt="no" Shift="no" Key="0">explorer $(CURRENT_DIRECTORY)</Command> 
  <Command name="Open current dir cmd" Ctrl="no" Alt="no" Shift="no" Key="0">cmd /K cd /d $(CURRENT_DIRECTORY)</Command> 
  <Command name="Send via Outlook" Ctrl="yes" Alt="yes" Shift="yes" Key="79">outlook /a "$(FULL_CURRENT_PATH)"</Command> 
  </UserDefinedCommands>
  <PluginCommands /> 
  <ScintillaKeys /> 
  </NotepadPlus>
  • Have a look in \program files\notepad++\shortcuts.xml to see if "Launch in Firefox" is register. – cfreire May 6 '13 at 18:20
2

Copy the lines corresponding to the missing shortcuts from \program files\notepad++\shortcuts.xml (Or what you pasted in your question) to %appdata%\Notepad++\shortcuts.xml

2

You don't specify which version. I am using 6.3.2 and they are shown in the Run menu. Perhaps they were deleted from the Shortcut mapper. Here is the screenshot from mine:

enter image description here

-1

OK... I noticed what was happening in mine and brought it all back. When I went to edit the shortcuts.xml file I noticed that the options we are looking for were blocked with a warning. I took my chances and unblocked them. Now I got them back. So, unblock the options.

enter image description here

  • 1
    The author already has that section uncommented. While you have solved your issue with your solution, your solution in this case, is not applicable to the author's question. – Ramhound May 14 '19 at 14:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.