I'm working on migrating a network share drive to a new network share drive (don't ask me where the roi is on this project).

When copying one of the folders I got an error. Long story short there was two files that were named the same in the same folder!!!

How is this possible?

I changed the name of one and everything was fine. But now I really want to know what happened. I've tried changing it back to the way I fond it but it's wont let me (obviously).


EDIT: The case was the same in both and it's on a windows box. How do I check too see if there are speical chararter?

  • Best way might be to read the directory entry and look at it with a debugger or use a discmonitor tool. I know there are such tricks under Unix. I'm not aware of such tricks for Windows, but of course this doesn't mean they might not exist. :) Could also have been a bug in the filesystem, but since Windows has many years on it's shoulders I doubt it. Of course if a tool was running which does lowlevel manipulations on the disc, it likely can do such things.
    – Devolus
    Apr 26, 2013 at 8:22

4 Answers 4


Maybe the filenames had hidden undisplayed characters in them.

Maybe the filenames had different characters in them that hust happen to look the same when they really are not.

Maybe the filesystem is configured to enable MSDOS 8.3 short names, and the files produced different short names but had the same long filenames for display purposes.

Hard to say without knowing what the original filenames actually were.

  • "Maybe the filenames had hidden undisplayed characters in them." - I don't think so because I add a '2' to one and now when I try to take the '2' out it won't let me rename it back to what is was "Maybe the filenames had different characters in them that hust happen to look the same when they really are not. - no because it errored when I tryed to copy both to a new folder.
    – rdman123
    Apr 25, 2013 at 19:29

It could be that a file with duplicate name exists in two folders in one library. I tested this by creating two diff word files and saved them with the same file name in "documents" folders under my use id and under the "public documents" folder. Then I used file explorer to browse the "document" library. I see two files with the same name. When I open them, they have different content.


Maybe there were some hidden characters in the name, that were not displayed. Did you look at the directory entry with a debugger or special tool reading the filestructure, or just some user tool?

If the file is on a Unix machine it might also be that the filenames only differed in the case, did you check that?

  • added an edit to my question
    – rdman123
    Apr 25, 2013 at 18:28

Just some thoughts (I was looking for something else and found your question): maybe the copy procedure converted the Unicode encoded characters in the name to some other format, or stripped some characters off of one of the names, so that the names of the files would only contain a set of characters that a given filesystem allows (i.e. NTFS forbids chars like * : ?) (you've said that you were using network shares). Maybe there was a space in the filename that got truncated while the copy procedure worked? Also, can you post a screenshot of how it looks like?

If files were on a shared folder, how do those files look 'locally' on the PC that shared the files?

//edit: I was looking for: why Windows does not allow me to create a file w/o the extension and a folder with the same name as the file in the same folder)

Could the files be junction points, hard links, mount points (reparse points)?

How do those files look from the command line?


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .