The problem that I am running into is that when I cd into my Applications folder and try to ls to see all my folders it doesn't show anything. This is the only directory that does this as I am able to go to any of my other directories and use the usual commands. Another thing that I tried was to jump to a path from my home directory to a folder within the Applications folder and I get No such file or directory. I input the path both with and without quotes and still nothing:

cd ~/Applications/MAMP/bin


cd ~/'Applications/MAMP/bin'

I am using the standard Terminal provided and haven't messed around with any settings. Thanks in advance!

  • 2
    maybe your apps are in /Applications and not in ~/Applications? – kch May 8 '13 at 13:01
  • Tried it a no luck. It is weird because if I ls the root directory the Applications folder shows up so I cd into it and it shows that I am currently in that directory. But from there if I try to ls within it nothing happens – Julian Feliciano May 8 '13 at 13:45
  • Are you on OSX? What are you expecting to see in /Applications and/or ~/Applications? – ForeverWintr May 8 '13 at 19:00
  • 1
    might help to see a full transcription of your terminal operations here. – kch May 10 '13 at 15:54

I had to type in:

cd /

to bring me to the root directory. Then you type in


and it displays all of the applications.

I think that it puts all of your applications for all the users into the root folder directory so all of the different users can access them. My personal folder/applications was empty.


This answer only addresses how to work around the problem. Since many users entering relevant queries on Google have a problem to fix ASAP. This allows you to be able to enter into your targeted directory from the command line. Some finding this thread may have ran into this problem where you don't see the application that you need

enter image description here

You can find the folder on your graphic interface then right click and select Get Info

enter image description here

Then copy the link provided (from the Get Info)

enter image description here

Now go back into the terminal and cd into it. For example, if you were working on a WordPress project (as in my example) you would

cd /Applications/XAMPP/xamppfiles/htdocs

This means when you are in the terminal, type cd, then hit space, then paste the link you copied, then hit enter.

  • So first you say to cd Applications/ from ~ (the / at the end is unnecessary, BTW), but then you also say to cd /Applications/....  Which is it? Also, please try to avoid posting images of text.  A reader should be able to get the answer without seeing the images.  Images should supplement the textual content of your post. – Scott Apr 10 '20 at 21:10
  • @Scott i never contradicted myself. Anyone that is using WordPress will see the clear difference. The second instance is just an example of when you want to go directly into one of the subdirectories. And no, i will post images of text if i want because I know they have been helpful. You can feel free to suggest an edit that adds the relevant text. – JGallardo Apr 18 '20 at 17:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy