I want to create a folder on a domain joined Windows server (NTFS), which any user can generate logs files to. When I say any user, this may include built in Windows user accounts, and from any OS environment such as WinPE.

I have created a folder on the server (2k8 R2 SP1), set the share and NTFS permissions to allow full control for anonymous logon, everyone, authentication users, users, domain computer, domain users, but still I am prompted for credentials when attempting to create log files in the folder!

Hence my question - How can I create a truly open access shared folder for logging?


2 Answers 2


Even if you have the proper permissions you must disable 'Password protected sharing' to allow 'Everyone' (Guest) access to the shares.

The quickest way to do is to right click any folder, choose 'Sharing', then 'Network and Sharing Center', then 'All networks' and finally 'Turn off password protected sharing'.

  • 1
    Is there a way to disable password protected sharing for just one share. So if the user gets a password prompt and cancels out they can still access the share?
    – majinnaibu
    Nov 22, 2015 at 6:14

Have you edited the Share permissions? When accessing a shared folder, both Share and NTFS permissions are applied. You changed NTFS permissions but the Share permissions may still not allow anonymous write access.

  1. Open the properties of the folder,
  2. Click Share tab,
  3. Click Advanced sharing, and
  4. Click Permissions.
  5. Select Everybody in the list Group or user names, and
  6. Select Full Control check box in Allow column.
  7. Click OK three times to close the dialogs.
  • You have not read my opening post properly! It clearly states that I have set both share and NTFS permissions.
    – MikeC
    May 21, 2013 at 15:40
  • 1
    @MikeC You're right, I missed the part where share permission were set. Anyway I'd recommend you to do auditing on the folder so that you can understand what and where fails to authenticate correctly and why Windows asks for explicit credentials. Jun 6, 2013 at 8:06
  • It's official, this doesn't work. Mar 10, 2016 at 21:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .