Not having found any, I stumbled upon this post that explains how to install ngIRCd with homebrew and I decided to give it a try.

First off I ran the ruby script and successfully installed HomeBrew: it did however return an error about its sbin not being in my path. Therefore I ran homebrew doctor and it returned the following error:

Warning: Homebrew's sbin was not found in your path.
Consider amending your PATH variable so it contains:

I found a post that suggested editing the /etc/paths file so that the /usr/local/bin line came before the /usr/bin line: I edited the file by SFTPing into my server and now its contents are:


However the error persisted. I found this other post and tried entering export PATH="$PATH:/usr/local/sbin" in the terminal and tested the HomeBrew config again and this time it reported no errors.

Happy of the results I went on to install ngIRCd following the first post. I entered brew install ngircd and it did all of its magic without reporting any errors. I then went on with step two and pasted the vi ~/.bash_profile command in the terminal window but a series of lines with a $ sign at the beginning appeared and I couldn't get it to work. I closed the window, opened a new one, and typed in ngircd to start the server and it gave me a

bash: command not found


However entering the export PATH="$PATH:/usr/local/sbin" command once again in the new window followed by the ngircd command didn't return any errors. Therefore I went on and customized the ngIRCd config file in /usr/local/Cellar/ngircd/20.1/etc/ngircd.conf and tried logging into the server via Adium, only to get an Access denied: bad password error... I even restored the original .conf file to no avail. And of course there's the problem that I have to enter the export PATH command every single time I log into terminal. What am I doing wrong? I'd be happy to explore completely different solutions of course if there's some kind of guide i can follow!

I think this is how it went, but I might have missed or forgotten a few details. I hope this makes sense to someone among you out there xD


Ok so I finally found the solution. Apparently it was very simple and straightforward.

I gave the aforementioned post a second look and this answer proved to be the key. I looked up how to create a .bash_profile file and found this tutorial to be very helpful. After creating the file I pasted in the text from the answer linked above (export PATH="$PATH:/usr/local/sbin") with no brackets or spaces before or after and saved the file. As indicated in the same answer I then ran source ~/.bash_profile in the terminal and I restarted just to be on the safe side. After reboot I ran brew doctor once again this time finding it to be working properly reporting no errors. I then uninstalled ngircd via homebrew and reinstalled it following the post linked above in my original question. I started up ngircd and the Access denied error was gone.

I hope this helps someone out there.

Thanks everybody anyway: I love the community and I look forward to be part of it in the future :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.