I have a windows host and a linux (ubuntu) guest.


HOST - Windows 7

GUEST - Ubuntu 12.04.2 LTS

VMWARE TOOLS installed (output from vmware-toolbox-cmd -v): (build-799703)

Vmware Workstation: 9.0.0 build-812388

I installed vmware tools following the instructions and it seems like everything worked as I can copy paste between host and guest and drag drop files as well as other features that you can do with vmware tools. In addition when I run the command:

initctl list

I see:

vmware-tools start/running

which I guess would indicate that vmware-tools are indeed running.

However, when I try to run vmware-toolbox it tells me:

vmware-toolbox: command not found

After issuing a locate vmware-toolbox it cannot find it anywhere. I do see /usr/bin/vmware-toolbox-cmd but that command doesnt do anything.

What is going on here?

  • What versions are you using? What versions of Windows, Ubuntu, all that information is important. Update the question with this information. – Ramhound May 10 '13 at 17:08
  • @Ramhound OK, updated – Isopycnal Oscillation May 10 '13 at 17:16
  • You skipped which version of the Tools and Toolbox you have installed or are trying to install. – Ramhound May 10 '13 at 17:21
  • @Ramhound OK done, hope that is all you need. – Isopycnal Oscillation May 10 '13 at 17:25

There is no GUI interface called vmware-toolbox with vmware player 5 (and other newer products), as per Installing and Configuring VMware Tools:

The graphical user interface for VMware Tools, which is sometimes called the VMware Tools control panel and which is available from the notification area in the guest operating system, has been deprecated

You can however find settings for the toolbox, say "Update automatically", in the graphical user interface of the VMWare Player on the host (as in Player -> Manage -> Virtual Machine Settings -> Options -> VMware Tools).

As for "vmware-toolbox-cmd doesn't do anything"? You bet it does, read the doc above.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.