7

When I am in Chrome (Or IE8), and I want to open a link in a new tab, I'm used to using the middle (wheel) button.

With Windows 7, click on the mouse wheel brings up the Task Switcher, but I would rather that it still work in Chrome and IE8 like before.

How do I disable (or change) the wheel click bringing up the Task Switcher?

11

On my Win7 machine clicking the mouse wheel does nothing. So this is probably done by the software that came with your mouse.

I suggest that you go to Control Panel / Mouse and find where you can change the behavior of the wheel button. You should set it to “Middle Click” or something similar to be able to use the wheel button as intended.

For example, this is how it looks for IntelliPoint:

image

|improve this answer|||||
  • 4
    If you want programs to be able to do the default action (like Auto-scroll thingy in browsers, etc.) set the Wheel Button to Middle Click and it'll be up to each program on how to handle it. If it's set to something else it won't work. – Joshua Oct 23 '09 at 13:58
  • @Joshua has actually the correct answer here. Setting Wheel Button to Middle Click relays to the app how the click should be interpreted. – Peter Lillevold Oct 28 '09 at 10:53
  • 1
    actually, clicking the middle mouse on windows starts the mouse-move scroll on scrollable pages – user1916182 Oct 27 '17 at 9:07
  • Intellipoint 8.1 seems to not have nearly this many options, can't disable wheel press. – tbone Jan 27 '18 at 5:52
  • This free 3rd party utility works for those who can't get the normal ways to work: highrez.co.uk/downloads/xmousebuttoncontrol.htm – tbone Jan 27 '18 at 6:29
2

I bought a new wireless microsoft mouse and keyboard and found unintentional scroll wheel clicks annoying when they caused inadvertent scrolling. So I installed free intellipoint software from microsoft. The software includes an option to disable the mousewheel click. Try this at your own risk. My mouse is a Wireless Mouse 1000. I selected the intellimouse option for comfortmouse 1000 or somesuch.

http://support.microsoft.com/kb/258785

|improve this answer|||||
1

The task switcher you refer to is called the "Flip" interface. The "Flip" interface is set as default when the "Middle-click" mouse wheel-button is used.

To disable this behavior globally:

  1. Go to Control Panel > Mouse >
  2. Change the Wheel-button drop-down menu from "Flip (default)" to "Middle-Click".
  3. Apply the Settings

To disable this behavior only for specific programs: (Blender for example needs the middle mouse button to rotate in 3D Viewer mode).

  1. Go to Control Panel > Mouse >
  2. Enable program-specific settings check-box.
  3. Press "Settings" Button.
  4. Press "Add..." Button in new panel display.
  5. Change the Wheel-button drop-down menu from "Flip (default)" to "Middle-Click".
  6. Apply the settings.
|improve this answer|||||
0

I have a laptop with a synaptics touchpad and 3 buttons underneath (zbook 15) and I was tired that anytime I tried to open a new Chrome tab by clicking the middle button on a link, Windows 10 would open the Cortana search menu. The solution to this problem is supposed to be setting the "Middle Button Action" on the touchpad settings to "Middle click", however, mine was already set that way. Just for testing, I selected any other option, applied the changes, and then selected "Middle click" once again, and the problem got resolved. Go figure.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.