I can't use Task Manager on Windows 8.

Whichever way I open it (keyboard shortcuts, .exe in System32, taskbar right-click menu), it only stays open for second. It does not simply freeze and crash as within the second it stays open I can click the 'More details' button and it would begin to respond before it closes.

I tried sfc, it reported finding problems it could not fix. I manually replaced all the problematic files in the CBS.log; this fixed other problems I'd had but Task Manager still wouldn't remain open.

I don't have Restore Points that point to before this started happening.

I tried opening Task Manager in Windows' Safe Mode and in a new user account; it still wouldn't work.

Also, I'll post and reports/logs you may need.


Try a System Restore to restore your computer to a couple of days ago.

I'm not running Win8, but assuming that you have Classic Start or Classic Shell installed (so that you have a Start button), I think you can get to System Restore just like with earlier versions of Windows:

Start -> All Programs -> Accessories -> System Tools -> System Restore

|improve this answer|||||
  • Completely missed that one. Although it should (can't imagine why it wouldn't) work, that still doesn't tell me why that problem showed up or how to specifically address it. I don't know what I'm looking for but I'll post whatever logs/do whatever tests you need; to know. – Noein May 12 '13 at 18:51
  • 1
    I see that you've added the note that you don't have any restore points from before this began happening. That's too bad. You might have a malware infection; killing task manager and your anti-virus program are just the sorts of things that some malware do. Perhaps Tdsskiller (from Kaspersky) or ComboFix (from BleepingComputer) would fix something. You might also try installing Process Explorer (from Microsoft), as an experimental workaround. It has an option to replace Task Manager – Dave Burton May 30 '13 at 19:17

If you disable Avast, (right click the icon,left click avast shields control, left click disable for 10 minutes), the task manager will open. Once open you can re-enable Avast.I don't know what causes the problem, but this does work.

|improve this answer|||||

Try to run sfc /scannow command in Command Prompt with administrative privileges.

The sfc /scannow command scans all protected system files and replaces incorrect versions with correct Microsoft versions.

|improve this answer|||||
  • I did try that. No luck. I'll make sure to add it to the list of what I did (in the question) but am waiting until I have a bigger update to edit. – Noein May 12 '13 at 18:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.