2

I'm trying to fade a video clip in and out with a duration of a few seconds, and ffmpeg seemed like the best way. The documentation mentions a fade option, and I have it working with a time in frames, but I really want to be able to use seconds.

Using the example from the docs, and adding the following to a working encode command:

-vf "fade=t=in:st=5.5:d=0.5"

I get:

[fade @ 0x102f009a0] Option 'st' not found
[AVFilterGraph @ 0x102f00d00] Error initializing filter 'fade' with args 't=in:st=5.5:d=0.5'

I get the same error using the long argument start_time

I have ffmpeg version 1.2 and libavfilter 3. 42.103 / 3. 42.103

I would use frames to specify the fade time and duration, but I'm specifying clip length in seconds, and I have no idea how long the clip will be in frames. To specify fade out I need to know the length in frames, and then specify the start time as num_frames - fade_duration_in_frames.

Has anyone else hit this problem?

migrated from stackoverflow.com May 13 '13 at 12:49

This question came from our site for professional and enthusiast programmers.

  • It is working for me. But I have Libavfilter version 3. 60.101 / 3. 60.101 which I retrieved from Git at 25th april. I think that is your problem, probably your old libavfilter version can't handle that option yet? – Nick van Tilborg May 13 '13 at 6:42
  • I downloaded the latest version from Git, rather than the static OSX build and the version on Brew. That was the problem. It seems Libavfilter isn't updated as much on there. Thanks! – Ben Humphreys May 13 '13 at 9:49
2

You are using an old version of Libavfilter where those filters are not yet implemented. I've tested it with a recent libavfilter version 3. 60.101 / 3. 60.101 and it is working correctly. Try building FFmpeg again using the current version and it should work for you too.

0

I am having the libavfilter 7. 16.100 / 7. 16.100 and got the same problem with st and start_time.

The actual problem might not be st or start_time. Check logs I got few other commands related problems in filter_complex. On checking the log and fixing it I didn't get any st and start_time related issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.