4

When I browse localhost in my browser when connected to the Internet, the response is slow; it takes 30 seconds or completely times out. When I disconnect from the Internet, it is blazing fast and loads instantly.

What is going on? This is very annoying. I'm using Windows 7 Home Premium with Apache installed.

No changes have been made to the system.

  • How about your network setting ? – matzone May 14 '13 at 8:08
  • @matzone: What network setting? – Codebeat May 14 '13 at 13:57
  • Your TCP/IP setting .. I don't know much about this, but mostly occured in DHCP setting .. – matzone May 14 '13 at 16:30
4

What's probably going on when you are connected to Internet is that your system tries to resolve name localhost in yours ISP DNS servers.

As a solution you can define name localhost as IP address 127.0.0.1 in your hosts file which is read before querying DNS servers. Since you have Windows 7 you should have required entry in C:\Windows\System32\drivers\etc\hosts file but by default it's commented out. Start Notepad as Administrator by right-clicking on it and choosing Run as Administrator. Open your hosts file and change lines:

#   127.0.0.1       localhost
#   ::1             localhost

to:

127.0.0.1       localhost
::1             localhost

Basically uncomment it by removing # from the beginning of these two lines. Save the file and test if it resolved your problem.

  • I appreciate your answer, but already tried that without success! One said that to remove it and the other said to add it. It makes really no sense to the problem. – Codebeat May 14 '13 at 13:56
2

Al right, it seems no problem of the system itself, windows or network but remove some hidden networkcard configurations from the past and disable all WAN-miniports in the hardware configuration that increases the speed a little.

But that was not the problem causing the long delays when connected to the internet. In the php code there was some cURL code that connects to a slow site to get some additional useragent info (REST interface). Because the data was not cached and the site access slow down in time for some reason, it connects to this slow site for each part of the webpage. This caused the long delays.

Now it is cached, the problem no longer exists. Thanks for the input anyway.

0

You have to make sure that all entries for 127.0.0.1 are placed on the same line in the hosts file. A configuration like this:

127.0.0.1 localhost
127.0.0.1 mysite

should be changed to:

127.0.0.1 localhost mysite

This small modification has increased the speed at my Windows based system incredibly.

  • Can you provide some evidence for the "speed increase"?. That change will only have a tiny effect on DNS lookups. – DavidPostill Apr 12 '16 at 13:04
  • I know in Linux this should not have any impact, but at my Windows setup I have struggled with this issue for months until I did the modification mentioned above. The change is dramatic. It was taking several seconds to load the page (especially first visit to site), now the pages get loaded instantaneously (no delays at all). – W.M. Apr 12 '16 at 13:54

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.