I have a problem with my Num. Lock key on my Toshiba Satellite C650. In fact, when I start up my computer the Num. Lock. button works fine, I can use it to activate the num pad and I even can type my password using the num pad but after authentication the num pad is automatically disabled and I can't activate it anymore, Num. Lock. seems to be useless once I get authenticated. I tried to change the Value of the Keybord Registry Key and uncheck Turn on mouse keys but this didn't solve the problem. I'm working on Windows 7 x64. Any help would be appreciated.

Update: num pad buttons work fine but not as numbers i.e: when I press 4 the cursor moves to the left. The problem is that I can't turn on the Num. Lock

  • Maybe try MS's fix once you're loggedin webcache.googleusercontent.com/…
    – Jan Doggen
    May 14 '13 at 10:36
  • @JanDoggen that's what I have tried manually
    – Kira
    May 14 '13 at 13:20
  • Go to Control "Panel\All Control Panel Items\Ease of Access Center\Make the keyboard easier to use". In this, under the "Control the mouse with the keyboard" section, make sure that "Turn on Mouse Keys" is unchecked
    – rags
    May 16 '13 at 9:28
  • It would probably help to know what kind of keyboard you have. Does the keyboard have a FN key? Is this perhaps a laptop? May 16 '13 at 9:31
  • @rags it's unchecked.
    – Kira
    May 16 '13 at 9:37

Use Win7 built-in "On Screen Keyboard" to test if NumLock behaves well.

  1. Press Windows Key+R

  2. Enter osk

  3. In bottom right corner, click "Option" and checked the Number Panel boxes

  4. Press NumLock

  • It's the only answer that helped me. But does this mean that the num lock button (of the real keyboard :p) doesn't work??
    – Kira
    May 22 '13 at 9:10
  • It need to be tested. If NumLock is an individual physical button, 1) Use "AutoHotKey", 2) enter .ahk script #InstallKeybdHook and 3) View>Key History to see if NumLock works or not. If it shows NumLock, then I suspect that some softwares may override the key. And sometimes clear dusts of the laptop may help.
    – Ivan Chau
    May 22 '13 at 14:31
  • it doesn't show NumLock. I guess it's broken. Anyway, thanks for your help :), at least now I know where it comes from and how to activate it. It was hard for me to use a keyboard without Number Pad.
    – Kira
    May 22 '13 at 15:58

Your issue definitely sounds software related. If you're certain you've disabled Mouse Keys from the Ease of Access Center, then it seems like some other software is providing Mouse Key functionality. Perhaps something from Toshiba. I would suggest looking through your startup items for anything that sounds like Ease of Access or Accessibility and disabling it. You can use msconfig to do this, but I would suggest using Autoruns from Sysinternals since it is more thorough.

If you do File > Save from Autoruns and send me the file, then I can look through it and tell you if there anything that might be causing it.

  • thank you for your answer, how can I send it to you, can you give me you email adress
    – Kira
    May 16 '13 at 10:31

.Hi Hedi!

You can try to check BIOS settings too, BIOS setting for num lock should not be conflicting with the registry details. Just click the correct key on your Toshiba to load the BIOS then view Boot Device Menu, choose System Setup, look for POST Behavior then check the Num Lock Key Option. Make sure its Num Lock is Turn On, Save and Exit the SetUp page before rebooting the computer.

Have a great day!



I had this problem once and it turned out to be an ease of access problem.

I'd recomend you go to:

Ease of Access Center under Make the keyboard easier to use and uncheck all the checkboxes you find there.

I don't know exactly what option I unchecked, but it's OK if you uncheck it all.

Hope it helps.


I was having the same issue. Turned my computer on this morning and the number lock wasn't working. I plugged in a different usb keyboard and windows downloaded driver for that keyboard. That keyboard worked with no issues so I tried the old keyboard and it seemed to fix that issue as well.

PS my virus scan had also remove 2 possible threats the night before...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.