0

I bought a new laptop (an Ideapad Yoga), and put Linux Mint on it. Everything seems to be working well, but Mint's default LOCALE settings for my language choice (en-CA... not sure why CA when I'm in the US) makes for alphabetical settings and ignoring the leading period in hidden files, scattering them among the rest.

This annoys me. Especially in Emacs.

Is there a way to use a UTF-8 compliant locale, but retain the ASCIIbetical sorting to which I'm accustomed?

1

Put

export LC_COLLATE=C

in your ~/.profile or ~/.bash_profile. The traditional location is ~/.profile, but some distributions now use other files for setting the environment before starting your window manager.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.