I have a computer acting as a local web development server using Ubuntu 12 with the desktop GUI. I am using SAMBA to share a folder in /var/www (i know this is not advised but it is sharing and this is local, I also changed the owner to user chad). I install samba on the ubuntu and I can see the folder but I cannot connect to the folder. Here is a copy of my smb.conf and also here are the things I tried:

  1. Created the shared folder using the samba gui server administration.
  2. Assigned the user to the folder and set the username/password
  3. Originally I just used workgroup and I figured that would work but did not. I then tried to change the workgroup name to s1domain and use it instead.

The problems is when I try to connect from Windows 8 it prompts me with a login. I have tried the following combinations:

  • s1\chad
  • s1domain\chad
  • workgroup\chad
  • chad

I am confused because when the prompt first comes up it has my comptuer name. What workgroup and domain am I suppose to use? I had this actually work one time then randomly stopped working. Also this works if I open the share to everyone.


workgroup = s1domain

        path = /var/www
        writeable = yes
    ;   browseable = yes
        valid users = chad

1 Answer 1


Could use a bit more info from your smb.conf. If that's really the only line in [global] maybe the output of 'testparm -sv' would help (and please no commented lines).

And is "chad" a valid samba user (did you add him to Samba with smbpasswd)?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .