I was currently running Win8 and F17 as a dual boot on my home desktop with an i5 chip and Asus UEFI BIOS. Unfortunately, while I was in Win8 I accidentally removed the partition that held my F17 OS.

Now whenever I boot I'm prompted with error: no such partiton. Entering rescue mode... and then the single prompt grub rescue>.

Now I've been searching the web for a solution to this problem, but I haven't found an answer yet. These are some of the methods that I've tried so far:

  1. Burned a Windows 8 Recovery DVD; wasn't recognized
  2. Tried creating a liveusb with F17 i686 desktop version
  3. Followed several different tutorials, using commands like insmod and makeactive but neither are recognized

Currently, I've found a a page in the Fedora Docs about editing the /etc/grub.d/10_linux file.

Is this what I have to do in order to fix this gigantic headache? If so, how do I go about doing this? I know that people have had this problem before; I've just been unable to find the solution myself.

Any help is greatly appreciated.

Edit1: When I tried to boot with the liveUSB, it wasn't recognized. Even though I set my boot priority to be USB first. I was still taken directly to the grub rescure> prompt.

Edit2: My BIOS Version is 3506 x64, CPU is an i5-2500K

  • 1
    You're going to have to boot from something other than your hard drive, whether it's a USB drive or a CD/DVD. Try this: superuser.com/questions/524598/…. Or post your specific motherboard name and bios version so people can give you specific suggestions. – stone May 15 '13 at 20:56
  • My BIOS recognizes the USB, but doesn't boot from it. Any ideas? I haven't had luck with DVDs. – piperchester May 15 '13 at 21:18
  • Set the top priority boot device to "hard drive." Assuming your USB drive shows up in the list of hard drives, move it to the top of the list. That's the only way I've ever had it work. Checking your specific BIOS to see what else looks promising... – stone May 15 '13 at 21:55

Press F8 while booting up, as soon as the ASUS logo appears. You have to do it very early in the boot sequence, so it may take you a few tries. Sometimes pressing it repeatedly as it boots works best. This should take you to the boot menu.

From there, choose your DVD drive or your USB drive. USB (flash) drive is likely to be under the list of hard drives or even SATA devices.

If you choose DVD drive and it spins the DVD drive, but still does not boot from it, then you may need to press Enter to confirm starting from DVD; if that's the case it will prompt you. If it spins the DVD (lights come on and drive makes noise), but still fails to boot, then there's probably something wrong with the DVD.

If both of those fail, try turning "Legacy USB support" either On or Off on the Advanced tab in the BIOS.

Trial and error is your friend in this case. Try every possible combination and one will work, assuming your DVD and/or USB drive are truly bootable. If you've got another system, try booting from the DVD and USB drive on that system to verify that they are indeed bootable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.