I just installed cups. When the webinterface asked me for username and password, I gave my regular user and not the root password. Now I can't log in (forbidden). I tried to clear the browsing data without success. What should I do?

  • 3
    As you already suspected, the login is stored in the browser. Most browsers will forget about this when restarted. – chirlu May 16 '13 at 17:33

As chirlu commented, restarting the browser solved this.

Alternatively, you can just delete the session cookie for cups.

Here's how to do this in Mozilla Firefox:

(I'm using Firefox in German, so your menu item names might differ)

  1. Open Menu → Settings (or type about:preferences into the address bar)
    In English this may be "Tools" → "Options".
  2. Select tab "Privacy"
  3. Click "[delete] individual cookies"
    In English this may be "Show Cookies..."
  4. Search for "localhost" (or whatever the URL is you're running the CUPS interface on), find the cookie called org.cups.sid or similar, and delete it.
  5. Reload the CUPS interface webpage, you should now be logged out.
  • This answer would be more usable if you would provide some instructions (i.e., explicit steps) for how to do this. – Scott Sep 1 '17 at 18:16
  • Sorry. Done! Added instructions for Firefox. – chaoscommander Sep 12 '17 at 10:27
  • Though it would seem the best solution, deleting the cookie doesn't seem to work on Firefox 52.9.0. Restarting the browser (no need to delete the cookie) worked. – Skippy le Grand Gourou Aug 16 at 10:16

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.